Debian GNU/Linux 2.1r4 udgivet

15. december 1999

En ny opdatering af Debian GNU/Linux 2.1-udgaven (alias slink) er blevet udgivet. Den nye udgave, version 2.1r4, indeholder både sikkerhedsopdateringer og år 2000-rettelser.

Pt. kender vi ikke til uløste år 2000-problemer. Bliver vi gjort opmærksomme på flere sådanne problemer, vil vi rapportere det på vores år 2000-side, http://www.debian.org/y2k/.

Her er en fuldstændig liste over pakker som er ændret i denne udgave:

Sikkerhedsopdateringer:
  pakke        : amd
  version      : 102-23.slink2
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : fjernudnyttelse

  pakke        : bind
  version      : 8.2.2p5-0slink1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : fjern-overbelastningsangreb

  pakke        : dump
  version      : 0.4b9-0slink1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : lokal udnyttelse

  pakke        : kernel-source-2.0.38
  version      : 2.0.38-0
  arkitekturer : i386
  sårbarhed    : diverse

  pakke        : htdig
  version      : 3.1.2-4slink6
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : fjern-udnyttelse

  pakke        : inn
  version      : 1.7.2-4.1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : retter bufferoverløb i inews

  pakke        : lpr
  version      : 0.46-1-0slink1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : lokal udnyttelse (brugere kunne udskrive
		 filer, som de ikke kunne læse)

  pakke        : mirror
  version      : 2.9-2.1
  arkitekturer : all
  sårbarhed    : fjernudnyttelse

  pakke        : netkit-telnet
  version      : 0.12-4slink.1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : fjern-overbelastningsangreb

  pakke        : nfs-server
  version      : 2.2beta37-1slink.1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : fjern-udnyttelse

  pakke        : nis
  version      : 3.5-2
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : fjern-udnyttelse

  pakke        : proftpd
  version      : 1.2.0pre9-4
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : fjern-udnyttelse

  pakke        : pvm
  version      : 3.4beta7-4
  arkitekturer : i386
  sårbarhed    : lokal udnyttelse

  pakke        : rvplayer
  version      : 5.0-9
  arkitekturer : i386
  sårbarhed    : lokal udnyttelse

  pakke        : termcap-compat
  version      : 1.1.2
  arkitekturer : i386 m68k (ej tillämpligt på alpha)
  sårbarhed    : lokal udnyttelse (bufferoverløb)

  pakke        : sendmail
  version      : 8.9.3-3slink1.0.1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : lokal udnyttelse

  pakke        : sendmail-wide
  version      : 8.9.3+3.2W-3slink1
  arkitekturer : alpha i386 m68k sparc
  sårbarhed    : lokal udnyttelse


År 2000-opdateringer:
  pakke        : cvs
  version      : 1.10.7-1.99.slink.y2k.0
  arkitekturer : alpha i386 m68k sparc
  problem      : dato i log

  pakke        : egcs
  version      : 1.1.2-0slink1 and 1.1.2-0slink2
  arkitekturer : alpha i386 m68k sparc
  problem      : datohåndtering i g77

  pakke        : elm-me+
  version      : 2.4pl25ME+65-0.slink.0
  arkitekturer : alpha i386 m68k sparc
  problem      : fejlagtig håndtering af lange tal gav fejl
		 i datosortering

  pakke        : enscript
  version      : 1.6.2-3.99.slink.y2k.0
  arkitekturer : alpha i386 m68k sparc
  problem      : versioner < 1.6.1 har problemer med år
		 2000-datoer

  pakke        : gnats
  version      : 3.113-0slink1
  arkitekturer : alpha i386 m68k sparc
  problem      : retter et år 2000-problem

  pakke        : gs
  version      : 5.10-3.99.slink.1
  arkitekturer : alpha i386 m68k sparc
  problem      : retter et år 2000-problem

  pakke        : sharutils
  version      : 1:4.2.1-1
  arkitekturer : alpha i386 m68k sparc
  problem      : datohåndtering i shar-filer

  pakke        : smartlist
  version      : 3.13-2
  arkitekturer : alpha i386 m68k sparc
  problem      : volumennummer i digest-håndtering


Øvrige opdateringer:
  pakke        : boot-floppies
  version      : 2.1.12
  arkitekturer : i386
  problem      : opdatering til 2.0.38-kernen

  pakke        : mew
  version      : 1.93-2
  arkitekturer : m68k
  problem      : synkronisering med de andre arkitekturer

  pakke        : pcmcia-cs
  version      : 3.0.5-10.slink.1
  arkitekturer : i386
  problem      : genoversættelse til 2.0.38-kernen

  pakke        : selfhtml
  version      : 7.0-3
  arkitekturer : alpha i386 m68k sparc
  problem      : varemærkeovertrædelse

  pakke        : trn
  version      : 3.6-9.3.2
  arkitekturer : m68k
  problem      : synkronisering med de andre arkitekturer

  pakke        : vflib2
  version      : 2.24.2-2.99.slink.0
  arkitekturer : alpha i386 m68k sparc
  problem      : kræves af ny gs

Bemærk:
* Opdateringen af nfs-server til sparc-arkitekturen har et længere versionsnummer end den version, som anvendes i den tidligere slink-udgave. Du skal manuelt opgradere til den nye version.