Notícias Semanais Debian (Debian Weekly News) - E-Mail

From: Grant Bowman <grantbow@svpal.org>
Date: Fri, 21 Dec 2001 12:44:29 -0800
To: dwn@debian.org
Subject: Pinning Unstable: Uso do Evolution no Woody

Para todos aqueles que estão usando o Woody mas que gostariam de rodar
pacotes da Sid as vezes, isso funciona bem. Eu não consegui
encontrar documentos específicos em nenhum outro lugar, mas achei
que outras pessoas gostariam de saber sobre isso.

/etc/apt/preferences

Package: *
Pin: release a=unstable
Pin-Priority: 50

/etc/apt/sources.list

deb http://http.us.debian.org/debian unstable main contrib non-free

O que essas linhas farão? Pinar a prioridade da unstable para 50
faz com que os pacotes nunca sejam selecionados automaticamente para
upgrade. A linha do sources.list é necessários para que pacotes que
não estão no woody sejam instalados com `apt-get install evolution'
(por exemplo). As dependências são manejadas corretamente e o
sistema continua com os pacotes do Woody, com excessão dos baixados
explicitamente.

Boas Férias,

--
-- Grant Bowman                                   <grantbow@svpal.org>

From: Christoph Martin <martin@uni-mainz.de>
Date: Sat, 22 Dec 2001 15:41:17 +0100 (MET)
To: dwn@debian.org
Subject: apt-show-versions

O apt-show-versions é um script que facilita a manutenção de
sistemas misturados, com stable/testing ou testing/unstable.
Atualizar os pacotes da sua distribuição *principal* com
apt-get upgrade é muito fácil, mas é muito difícil fazer isso
para os pacotes *não-principais*. Apesar de você poder usar
a função de pinning do apt se eles são poucos, é muito irritante
colocar todos os nomes dos pacotes no apt/preferences para
piná-los. Como em uma das minhas instalações eu tenho 247 pacotes
da stable e 229 da testing.

Tente

  apt-show-versions | fgrep /testing | wc

para ver quantos pacotes você tem da testing ou

  apt-show-versions -u

para ver uma lista dos pacotes que podem ser atualizados ou para
a stable ou para testing ou unstable ou

  apt-get install `apt-show-versions -u -b | fgrep unstable`

para atualizar todos os pacotes do unstable para suas versões mais
novas.

Christoph

Para receber este boletim semanalmente em sua caixa postal, inscreva-se na lista debian-news-portuguese (versão em Português Brasileiro). Para receber o boletim em inglês, inscreva-se na lista debian-news.

Edições anteriores deste boletim estão disponíveis.

Esta edição das Notícias Semanais Debian foi editada por Joe 'Zonker' Brockmeier e Martin 'Joey' Schulze.