Debian GNU/Linux 4.0 -- Notes de publication d'etch-et-demi

Vue d'ensemble

Des paquets additionnels ont été ajoutés à la version 4.0r4 de Debian afin d'augmenter la quantité de matériel géré par Debian 4.0 (Etch). Cela inclut des paquets basés sur le noyau Linux 2.4.24 et des pilotes additionnels pour le système X Window. L'installation de ces paquets additionnels n'est pas requise et n'aura pas lieu par défaut. Cette mise à niveau ne remet pas en question la maintenance des paquets disponibles précédents.

Le noyau existant basé sur la version 2.6.18 continuera à être le noyau par défaut pour la version Etch.

Nouveaux paquets disponibles

Paquets pour Etch mis à jour

Quelques paquets existants pour Etch ont été mis à jour pour ajouter la prise en charge de nouveau matériel et pour assurer la compatibilité avec le noyau 2.6.24 :

Installation de la version Etch-et-demi

A partir de cette version, il existe deux manières d'installer la version 4.0 (Etch) de Debian.

  1. Installation en utilisant l'installateur de Debian 4.0 (Etch)
    Si votre matériel est suffisamment pris en charge par l'installateur standard d'Etch, vous pouvez choisir d'utiliser le media standard pour réaliser l'installation initiale du système puis migrer vers le noyau etch-et-demi. Cette méthode est la meilleure pour les utilisateurs ayant déjà un système Etch ou qui ne désirent pas récupérer un nouveau média d'installation mais voudraient quand même ajouter du nouveau matériel qui n'est que géré par le noyau etch-et-demi.
    La page de l'installateur pour Etch explique comment obtenir et utiliser l'installateur Debian 4.0 (Etch).
  2. Installation en utilisant l'installateur actuel de Debian Lenny
    A partir de la Beta 2, le noyau compris dans l'installateur de Lenny possède des caractéristiques très semblables au noyau de Etch-et-demi et propose un mode de compatibilité pour installer la version Etch. Cette méthode est la meilleure pour les utilisateurs ayant du matériel géré par le noyau etch-et-demi mais pas par celui de l'installateur par défaut de Etch. La page de l'installateur pour etch-et-demi explique comment obtenir et utiliser l'installateur basé sur Lenny.

Limitations

Notes spécifiques au matériel