Annexe A. Gérer votre système etch

Table des matières

A.1. Mettre à niveau votre système etch
A.2. Vérifier votre liste de sources

Cette annexe contient des informations sur la façon de vous assurer que vous pouvez installer ou mettre à jour des paquets de etch avant de faire une mise à niveau vers Lenny. Cela ne devrait être nécessaire que dans des situations spécifiques.

A.1. Mettre à niveau votre système etch

Basiquement, cela n'est pas différent de toute autre mise à niveau de etch que vous avez déjà faite. La seule différence est que vous devez tout d'abord vous assurer que votre liste de paquets contient toujours des références à etch comme expliqué dans Section A.2, « Vérifier votre liste de sources » .

Si vous mettez votre système à niveau en utilisant un miroir Debian, il sera automatiquement mis à niveau vers la dernière version mineure de etch.

A.2. Vérifier votre liste de sources

Si l'une des lignes de votre /etc/apt/sources.list se réfère à « stable », c'est que vous « utilisez » déjà Lenny. Si vous avez déjà exécuté apt-get update, vous pouvez encore revenir en arrière sans problème en suivant la procédure ci-dessous.

Si vous avez déjà installé des paquets de Lenny, il n'y a probablement plus beaucoup d'intérêt à installer des paquets de etch. Dans ce cas, vous devrez décider vous-même si vous voulez continuer ainsi ou non. Il est possible de revenir à des versions inférieures pour des paquets, mais cela n'est pas couvert ici.

Ouvrez le fichier /etc/apt/sources.list avec votre éditeur favori (en tant que superutilisateurr) et recherchez une référence à « stable » dans toutes les lignes commençant par deb http: ou deb ftp:. Si vous en trouvez, changez stable en etch.

Si vous avez des lignes commençant par deb file:, vous devrez vérifier vous-même si l'emplacement auquel elles se réfèrent contient une archive d'etch ou de Lenny.

[Important]Important

Ne changez pas les lignes qui commencent par deb cdrom:. Faire cela invaliderait la ligne et vous devriez à nouveau exécuter apt-cdrom. Ne vous inquiétez pas si une ligne de source « cdrom » se réfère à « unstable ». C'est normal, bien que cela paraisse trompeur.

Si vous avez effectué des modifications, sauvegardez le fichier et exécutez :

# apt-get update

pour rafraîchir la liste des paquets.