[ zurück ] [ Inhalt ] [ 1 ] [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ A ] [ weiter ]


Release Notes für Debian GNU/Linux 3.1 (»Sarge«), ARM
Anhang A - Verwalten Ihres Woody-Systems


Dieser Anhang enthält Informationen, wie Sie sicherstellen können, dass Sie Pakete aus Woody installieren oder aktualisieren können, bevor Sie zu Sarge aktualisieren. Dies sollte nur in bestimmten Situationen notwendig sein.


A.1 Aktualisieren Ihres Woody-Systems

Im Grunde unterscheidet es sich nicht von jeder anderen Ihrer Woody-Aktualisierungen. Der einzige Unterschied ist, dass Sie zunächst sicherstellen sollten, dass Ihre Paket-Liste weiterhin die Pakete aus Woody enthält, wie es in Prüfen Ihrer sources.list, Abschnitt A.3 erklärt wird.


A.2 Installieren von aptitude aus Woody

Zunächst müssen Sie sicherstellen, dass Sie die aptitude-Version aus Woody installieren, und nicht die aus Sarge, indem Sie den Anweisungen in Prüfen Ihrer sources.list, Abschnitt A.3 folgen.

Anschließend führen Sie einfach

     # apt-get install aptitude

aus, um aptitude zu installieren.


A.3 Prüfen Ihrer sources.list

Wenn irgendeine der Zeilen in Ihrer /etc/apt/sources.list auf »stable« verweist, »benutzen« Sie eigentlich bereits Sarge. Wenn Sie bereits ein apt-get update ausgeführt haben, können Sie ohne Probleme mit dem unten beschriebenen Verfahren wieder auf den ursprünglichen Zustand zurückkommen.

Wenn Sie bereits Pakete aus Sarge installiert haben, hat es wahrscheinlich keinen Sinn mehr, Pakete aus Woody installieren zu wollen. In diesem Fall müssen Sie für sich selbst entscheiden, ob Sie weitermachen wollen oder nicht. Es ist möglich, Pakete zu de-aktualisieren, dies wird hier jedoch nicht behandelt.

Öffnen Sie (als root) die Datei /etc/apt/sources.list mit Ihrem bevorzugtem Editor, und schauen Sie, ob es dort Zeilen gibt, die mit deb http: oder deb ftp: beginnen, und auf »stable« verweisen. Ist dies der Fall, so ändern Sie stable zu woody.

Wenn Sie dort Zeilen finden, die mit deb file: beginnen, so werden Sie selbst prüfen müssen, ob der Ort, an den sie zeigen, Woody oder ein Sarge-Archiv enthält.

Wichtig! Ändern Sie keine Zeilen, die mit deb cdrom: beginnen. Dies würde diese Zeilen ungültig machen, und Sie müssten noch einmal apt-cdrom ausführen. Machen Sie sich keine Sorgen, wenn eine »cdrom«-Quelle auf »unstable« verweist – obwohl dies verwirrend ist, ist dies völlig normal.

Wenn Sie irgendwelche Änderungen vorgenommen haben, speichern Sie die Datei, und führen Sie

     # apt-get update

aus, um die Paket-Liste aufzufrischen.


[ zurück ] [ Inhalt ] [ 1 ] [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ A ] [ weiter ]


Release Notes für Debian GNU/Linux 3.1 (»Sarge«), ARM

$Id: release-notes.de.sgml,v 1.36 2005/09/04 10:10:14 jseidel Exp $

Josip Rodin, Bob Hilliard, Adam Di Carlo, Anne Bezemer, Rob Bradford (derzeit), Frans Pop (derzeit)
debian-doc@lists.debian.org