[ précédent ] [ Table des matières ] [ 1 ] [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ A ] [ B ] [ suivant ]


Notes de publication pour Debian GNU/Linux 3.1 (« sarge »), PA-RISC
Annexe A - Mettre à jour le noyau


Les instructions suivantes expliquent étape par étape comment utiliser les outils rétroportés disponibles pour installer le nouveau noyau.

Comme des paquets doivent être installés de woody, vous devriez tout d'abord vérifier que les entrées dans votre sources.list se réfèrent toujours à woody comme expliqué dans Vérifier votre liste de sources, Section B.2.

Téléchargez et installez les paquets nécessaires

avec apt : pour installer les paquets avec apt ou l'une de ses interfaces, ajoutez la ligne suivante dans votre /etc/apt/sources.list :

     deb http://ftp.debian.org/debian/dists/sarge/main/upgrade-kernel ./
     # les sources sont également disponibles si vous en avez besoin
     # deb-src http://ftp.debian.org/debian/dists/sarge/main/upgrade-kernel ./

Puis installez les paquets module-init-tools, modutils, palo, et initrd-tools :

     # apt-get install module-init-tools palo initrd-tools modutils

(Vous pouvez ensuite retirer à nouveau l'entrée supplémentaire.)

Après cela, changez votre fichier sources.list pour qu'il pointe sur sarge comme décrit dans Préparer les sources d'apt, Section 4.4, mettez votre liste des paquets à jour et installez le paquet kernel-image-2.6.8-2-64.

avec dpkg : pour installer les paquets directement avec dpkg, vous devez d'abord télécharger les fichiers nécessaires.

Le paquet de noyau dépend de module-init-tools (qui est en conflit avec l'ancien modutils) ; module-init-tools ; initrd-tools dépend de cramfsprogs. Toutes les autres dépendances (stat, cpio et ash) peuvent être satisfaites avec des paquets de woody de la façon habituelle.

Si vous utilisez LVM, vous devriez également installer lvm2 avant de redémarrer car le noyau 2.6 ne gère pas directement LVM1. Pour accéder aux volumes LVM1, la couche de compatibilité de lvm2 (le module dm-mod) est utilisé. Vous pouvez laisser lvm10 installé ; le script d'initialisation détectera quel noyau est utilisé et exécutera la version appropriée.

Ne supprimez pas encore votre ancien noyau

Vous devriez tout d'abord vérifier que le nouveau noyau s'amorce et que les périphériques matériels nécessaires à la mise à niveau fonctionnent (par exemple, les cartes réseau).

Rendez votre système amorçable

Vous devrez probablement adapter votre configuration de chargeur d'amorçage /etc/palo.conf. Notez que le noyau utilise maintenant un disque mémoire initial (initrd) alors que les noyaux Debian dans woody ne le faisaient pas.

Si vous utilisez actuellement raidtools2, vous devriez lire Faire une mise à jour de raidtools2 vers mdadm, Section 4.6.2 avant de redémarrer.

Redémarrez sur le nouveau noyau
Vérifiez votre système

Vérifiez en particulier les périphériques d'entrée, d'affichage, les périphériques nécessaires pour accéder aux paquets de sarge (par exemple, des cartes réseau, des lecteurs de CD, etc.). Certains modules de pilotes ont peut-être changé de noms, certains pilotes qui étaient compilés dans l'ancien noyau sont peut-être compilés en module, etc.


[ précédent ] [ Table des matières ] [ 1 ] [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ A ] [ B ] [ suivant ]


Notes de publication pour Debian GNU/Linux 3.1 (« sarge »), PA-RISC

$Id: release-notes.fr.sgml,v 1.38 2005/10/12 00:07:14 fbothamy Exp $

Josip Rodin, Bob Hilliard, Adam Di Carlo, Anne Bezemer, Rob Bradford (actuel), Frans Pop (actuel)
debian-doc@lists.debian.org