[ předchozí ] [ Obsah ] [ další ]

Release Notes for Debian GNU/Linux 2.1 (Slink) - Kapitola 2
Upgrade


Nehledě na metodu upgrade je doporučeno nejdříve zkontrolovat stav všech balíků. Nejépe příkazy dpkg -l | less nebo dpkg --get-selections > filename nebo přímo v programu dselect. Je třeba odstranit všechny označení `hold' před tím, než provedeme upgrade. Jestliže balík na upgradovaní bude `hold', upgrade se neprovede. `Hold' může být odstraněno v dselectu nebo editací souboru, který vznikne příkazem dpkg --get-selections > filename změnou "hold" na "install". Pak, s přístupovými právy uživatele root, zadejte dpkg --set-selections < filename.

Veškeré instalační operace musejí být prováděny s právy superuživatele, bude třeba přihlásit se k systému jako root nebo použít programů su nebo sudo k získání těchto práv.

Důrazně doporučujeme použít /usr/bin/script k záznamu průběhu upgrade -- vlastně je dobrý nápad použít script k záznamu jakékoli práce v programu dselect (nebo v jakémkoli jiném, ze kterého chcete pořídit záznam). Jestliže se objeví nějaký problém, minimálně uvidíte, co se stalo. script zapíše protokol do vámi zadaného souboru (script filename) nebo do souboru implicitního typescript.

Existují dvě cesty jak upgradovat na sling -- použití apt-get přímo nebo použití dselect.


2.1 Použití apt-get

Jestliže nemáte nainstalované apt doporučujeme download a instalaci z ftp://ftp.debian.org/debian/dists/slink/main/binary-alpha/admin/apt_*.deb. V závislosti na prohlížeči, který používáte, můžete potřebovat ještě speciální akci, aby se soubor stáhnul (download) v syrovém (raw), binárním modu. Například v Netscapu je třeba přidržet klávesu shift, když klikáte na URL, aby jste si soubor stáhli. Balík instalujete (jako root) příkazem dpkg -i apt*.deb.

Jestliže instalujete z CD-ROM, můžete instalovat přímo. Spusťte jako root

     
     dpkg -i cd_mount_point/debian/dists/slink/main/binary-alpha/admin/apt*.deb

Doporučujeme nyní přečíst manuálové stránky apt-get(8) a sources.list(5). Před provedením upgrade bude třeba nastavit konfigurační soubor /etc/apt/sources.list. Přednastavená konfigurace je vhodná pro instalaci přes Internet.

Jestliže instalujete z CD-ROM, doplňte jako první řádku po komentářích:

     
     deb file:cd_mount_point/debian stable main

Jestliže nejste připojení k Internetu (nebo nechcete stáhnout nejnovější bezpečnostní úpravy), zakomentujte další dvě řádky. Nebo můžete vybrat nejbližší mirror (zrcadlový server).

Když jste nakonfigurovali apt, spusťte:

     apt-get update
     apt-get -f dist-upgrade

Jestliže je k dispozici balík novější než instalovaný apt-get jej vezme a upgraduje balík starý. Nikdy nejsou odstraňovány instalované balíky, nikdy není do systému přidán balík, který by v něm předtím nebyl. Nové verze starých, instalovaných balíků, které nemohou být instalovány bez porušení instalačního statutu jiného balíku budou ponechány v jejich současné verzi. Proto bude nutné použít dpkg nebo dselect k odstranění nebo přeinstalování některých poškozených balíků nebo závislostí.

Přepínač -f (fix) způsobí, že apt se pokusí opravit systém s nekorektními závislostmi. apt neumožňuje v systému existenci závislostí mezi poškozenými balíky. Je možné, že struktura systémových závislostí může být do takové míty poškozena, že to bude vyžadovat ruční zásah (což v podstatě znamená použít dselect nebo dpkg --remove balík k odstanění konfliktních balíků).

Jesliže i po těchto dvou příkazech zahlásí apt existující poškozené balíky, pokuste se zpravit systém (pravděpodobně odstraněním poškozených balíků a instalací balíků odstraňujících chybějící závislosti). Jesliže z nějakého důvodu nemůžete opravit systém tak, jak by si přál apt, musíte k provedení upgrade použít program dselect (s metodou nesouvisející s apt).


2.2 Použití dselectu

Tato kapitola předpokládá, že jíž máte nějaké znalosti týkající se programu dselect. Po tom, co jste nainstalovali systém, se snažíte jej upgradeovat, nebo ne? Pro případ, že si potřebujete osvěžit paměť, existuje průvodce programem dselect pro začátečníky, najdete jej na dselect Tutorial.

První krok při použití programu dselect je výběr přístupové metody (Access method). Více informací o přístupových metodách najdete v dselect Tutorial.

Přístupová metoda `apt' pro dselect je v současnosti tou nejrychlejší. Instaluje a konfiguruje balíky ve sousledné sekvenci, takže nejsou žádné problémy se závislostmi, když se rozbalují jednotlivé balíky, tím pádem se nemusí instalace vícekrát opakovat. Jesliže je ve vašem systému nějaký balík poškozen do té míry, že apt-get upgrade není použitelný, potom selže i přístupová metoda `apt'.

Přístupová metoda `mounted' nejprve nainstaluje a nakonfiguruje předzávislosti, které snižují počet nezbytných instalačních průchodů. Přístupová metoda `mountable' se také nejprve snaží nainstalovat a nakonfigurovat před-závislosti, a je relativně rychlá.

Verze přístupové metody `http' z distribuce `hamm' neovládala předzávoslosti úplně správně; nedoporučujeme ji. Jestliže je tato verze dpkg-http použita k upgrade, pro každou předzávislost se zobrazí otázka Abort automatic installation (Y/n)?, tzn. Přerušit automatickou instalaci (A/n)?. Vzhledem k chybě v dpkg-http z distribuce hamm můžete v tomto okamžiku stisknout Ctrl-C namísto Y a ručně instalovat (dpkg -i) vyžadovaný balík. Program dselect může být posléze restartován, aby našel další předzávislost. Jestli chcete ušetřit čas, měli byste nainstalovat ručně tyto balíky ze slinku: libc6, libncurses4, libreadlineg2, libstdc++2.9, slang1, a libhtml-parser-perl.

Obecně se doporučuje nejprve provést upgrade vašich stávajících balíků před tím, než začnete přidávat další. Na počátku proveďte v dselectu jednotlivé kroky ``Access'', ``Update'', a ``Select''. Jakmile vstoupíte do menu ``Select'', stiskněte klávesu Enter. Zobrazí se vám obrazovka s řešením problémů mezi závislostmi. Po vyřešení všech konfliktů (obvykle můžete pouze stisknout Enter), spusťte ``Install'' a poté ``Configure'', tím provedete jednoduše upgrade všech nainstalovaných balíků. Nyní, jestliže chcete, můžete provést výběr a instalaci dalších balíků pomocí ``Select'' a ``Install''.

V případě, že dpkg nebo dselect upgradeují hodně balíků, je zpravidla nezbytné opakovat instalační a konfigurační kroky několikrát, než se celý systém nainstaluje. U některých typů přístupových metod je vhodné mezi jednotlivými instalačními průchody opakovat krok ``Update''. Může být užitečné bezprostředně před krokem ``Update'' ukončit a restartovat dselect.


2.3 Všeobecná varování

Neměli byste spouštět upgrade z jakékoliv X session řízené utilitou xdm. xdm a xfs jsou během upgrade zastaveny, takže by se vám mohlo stát, že bude upgrade náhle přerušen díky tomu, že X se náhle ukončí. Jestliže máte stroj nastavený na automatické zavedení X při startu celého systému, může být složité to spravit. Jestliže se váš X server dožaduje služby font serveru xfs na upgradeovaném počítači, spojení se přeruší jakmile se na serveru xfs zastaví. Te nemusí nutně vést k pádu X, ale na druhou stranu to může pěkně znepříjemnit práci. Jestliže si nejste jisti, zda je vaše X session obstarávána pomocí xdm nebo ne, proveďtě upgrade vašeho stroje z virtuální konzoly.

Neměli byste provádět upgrade pomocí vzdáleného spojení s hostitelem, pokud jste nejprve nenainstalovali balíky net a telnetd z distribuce slink. Když je starší balík netstd vyjmut, ukončí se vzdálená relace a vy nebudete schopni se znovu spojit, dokud nebude nainstalovaný balík telnetd.


[ předchozí ] [ Obsah ] [ další ]
Release Notes for Debian GNU/Linux 2.1 (Slink)
version 2.1.11, 28 August, 1999
Bob Hilliard hilliard@debian.org
Adam Di Carlo