[ natrag ] [ Sadržaj ] [ dalje ]

Napomene izdanja za Debian GNU/Linux GNU/Linux 2.1 (Slink) - Glava 3
Nadograđivanje


Prije nadograđivanja sustava, toplo se preporuča snimanje potpunog backupa, ili barem podataka ili konfiguracijskih datoteka čiji si gubitak ne možete priuštiti. Alati i postupak nadograđivanja su prilično pouzdani, ali hardverski kvar tokom nadogradnje bi mogao uzrokovati katastrofu.

Bez obzira na metodu nadograđivanja, preporuča se prethodna provjera stanja svih paketa. To se može učiniti pomoću dpkg -l | less ili dpkg --get-selections > datoteka, ili putem dselecta. Poželjno je prije nadograđivanja ukloniti sve holdove. Ako je bilo koji essential paket na holdu, nadogradnja neće uspjeti. Holdovi se mogu ukloniti u dselectu, ili mijenjanjem "hold" u "install" u datoteci stvorenoj pomoću dpkg --get-selections > datoteka. Zatim, uz root dozvole, pokrenite dpkg --set-selections < datoteka.

Svaka radnja instalacije paketa mora se obaviti uz povlastice nadkorisnika, pa se ili logirajte kao root ili, koristite su ili sudo kako biste zadobili te povlastice.

Toplo se preporuča korištenje /usr/bin/script za snimanje prijepisa nadogradnje -- zapravo, pametno je koristiti script za snimanje svake dselect sesije (i svega ostalog što je poželjno snimiti). Onda, ako dođe do problema, možete vidjeti što se dogodilo. script će zapisati taj prijepis u datoteku zadanu kao argument (script datoteka), ili u predodređenu datoteku, typescript.

Ako još niste instalirali apt, predlažemo vam da ga skinete i instalirate, iz ftp://ftp.debian.org/debian/dists/slink/main/binary-m68k/admin/apt_*.deb. Ovisno o vašem browseru, možda ćete morati poduzeti posebne mjere kako biste skidali izravno u datoteku, u sirovom binarnom modu. Na primjer, u Netscapeu morate držati tipku shift pri klikanju na URL kako biste skinuli datoteku. Kao root instalirajte skinuti paket naredbom dpkg -i apt*.deb.

Ako instalirate s CD-ROM-a, možete ga instalirati izravno s CD-ROM-a. Kao root pokrenite

     
     dpkg -i točka_montiranja_CD-a/debian/dists/slink/main/binary-m68k/admin/apt*.deb

Preporuča se da sada pročitate man stranice apt-get(8) i sources.list(5). Prije početka nadogradnje, morate namjestiti aptovu konfiguracijsku datoteku, /etc/apt/sources.list. Predodređena konfiguracija odgovara instalaciji preko Interneta, ali možda ćete željeti promijeniti /etc/apt/sources.list tako da se koriste drugi mirrori ili vaš lokalni mirror. Ako instalirate s CD-ROM-a, pogledajte Nadogradnja s CD-ROMs:, Poglavlje 3.1.

Nakon što podesite apt, (kao root) pokrenite:

     apt-get update
     apt-get -f dist-upgrade

Neki ljudi više vole prije apt-get -f dist-upgrade pokrenuti apt-get -f --dry-run dist-upgrade | less kako bi vidjeli što će se dogoditi. Iako to može oduzeti dosta vremena, može izbjeći neka iznenađenja.

Ako budu dostupne nove verzije trenutno instaliranih paketa, apt-get dist-upgrade i apt-get upgrade će ih skinuti i nadograditi; ni u kojem slučaju neće uklanjati trenutno instalirane pakete, niti instalirati nove pakete. Nove verzije trenutno instaliranih paketa koje se ne mogu nadograditi bez mijenjanja instaliranog stanja drugih paketa bit će ostavljene u svojoj trenutnoj verziji. Dakle, može biti potrebno korištenje dpkga ili dselecta za uklanjanje i ponovno instaliranje nekih potrganih paketa ili zavisnosti. Alternativno, nakon apt-get -f dist-upgrade može se koristiti apt-get dselect-upgrade. (Pogledajte man stranicu apt-get(8).)

Uz opciju -f apt će pokušati srediti sustav sa nezadovoljenim zavisnostima. apt ne dopušta postojanje nezadovoljenih zavisnosti na sustavu. Moguće je da struktura zavisnosti na sustavu bude tako pokvarena da je potrebna ručna intervencija (što obično znači koristiti dselect ili dpkg --remove paket kako bi se uklonili neki od zahvaćenih paketa).

Ako apt izvijesti o nekim potrganim paketima nakon tih dviju naredbi, pokušajte popraviti sustav (možda uklanjanjem strganih paketa ili instaliranjem nedostajućih zavisnosti). Ako ne možete popraviti sustav na zadovoljstvo apta, morate nadograđivati dselect metodom (pomoću ne-apt potpore).


3.1 Nadogradnja s CD-ROMs:

aptov kod za rad s višestrukim CD-ROM-ovima nije završen na vrijeme za objavljivanje slinka, ali postoji zaobilazno rješenje. Dodajte ovo u /etc/apt/sources.list kao prvi red nakon komentara s uputama:

     deb file:točka_montiranja_CD-a/debian stable main

Ostale `deb' redove treba zakomentirati stavljanjem # ispred njih.

Zatim ubacite prvi binarni CD, montirajte ga, i kao root pokrenite

          apt-get update 
          apt-get dist-upgrade

Kao što je gore spomenuto, prije apt-get dist-upgrade možete pokrenuti apt-get -f --dry-run dist-upgrade | less kako biste izbjegli iznenađenja.

Dok je prvi CD još montiran, bilo bi dobro da pokrenete apt-get install dpkg-multicd.

Demontirajte prvi binarni CD, zamijenite ga drugim binarnim CD-om, i montirajte njega. Zatim promijenite red u /etc/apt/sources.list u

          deb file:točka_montiranja_CD-a/debian stable main contrib

i ponovite korake update i dist-upgrade kao gore.

Nakon nadograđivanja, demontirajte posljednji CD-ROM, ali ga ostavite u CD-ROM pogonu. Zatim pokrenite dselect. Izaberite [A]ccess, pa novu multi_cd metodu instalacije, napišite točno ime uređaja i pritisnite Enter na sva ostala pitanja (pritom drugi binarni CD-ROM mora biti umetnut!). Izaberite [U]pdate. Zatim izaberite [S]elect; pritisnite razmak kako biste izašli iz zaslona pomoći. U zaslonu za izbor paketa pritisnite Shift-D i nakon toga odmah Enter. Vrlo vjerojatno će biti nekih konflikata među zavisnostima, u slučaju kojih ćete vidjeti zaslon pomoći. Izađite iz njega pritiskom na razmak i pregledajte ponuđeni popis paketa. Možete mijenjati zadana stanja, ali to se ne preporuča; pritisak na Enter bi trebao zadovoljavajuće riješiti sve zavisnosti/konflikte.

Onda izaberite [I]nstall. Nakon toga obično je potreban još jedan [C]onfigure. Zatim ubacite prvi binarni CD i ponovite postupak. (Ovaj postupak u dselectu je potreban jer je xbase na drugom CD-u, a neke od njegovih zavisnosti na prvom.)

Službeni Debian CD set sadrži dva binarna CD-a. Neki distributeri nude set s tri binarna CD-a, uključujući djelomično ili u cjelini non-free i/ili non-US. Ako imate treći binarni CD, demontirajte drugi CD te ubacite i montirajte treći. Promijenite red u /etc/apt/sources.list u

        deb file:točka_montiranja_CD-a/debian stable non-free non-US

(Izostavite non-free odnosno non-US ako ih vaš CD ne sadrži.)

Onda ponovite korake update i dist-upgrade kao gore. Primjetite da ćete nakon tog koraka morati ponovo izabrati [A]ccess i [U]pdate u dselectu, kao gore. Nekoliko verzija takvih neslužbenih trećih binarnih CD-a ima strukturu koja omogućava da budu ubačeni dok se obavljaju koraci [A]ccess i [U]pdate; ako imate takav CD, paketi sa sva tri CD-a će biti istodobno dostupni iz dselecta.

Postoji ``neslužbena alternativa'': korištenje potato verzije apta, 0.3.x. Shvatite da je apt 0.3.x još u beti, pa su bugovi vjerojatno još uvijek prisutni. Jason Gunthorpe, jedan od glavnih autora apta, kaže:

Pravo rješenje je instalirati apt 0.3 iz potatoa i koristiti njegove ugrađene CD metode preko apt-cdroma. Napravio sam poseban izvorni kod baš za to, kojem se može pristupiti dodavanjem reda ``deb http://www.debian.org/~jgg apt/'' u sources.list, te pokretanjem apt-get update; apt-get install apt.

Ova verzija sadrži najnoviji apt 3.x linkan na glibc 2.0. Instalirajte koji god apt možete, dodajte gornje u sources.list (i možda privremeni ``file:'' URI za prvi CD-ROM) i zatim pokrenite ``apt-get install apt''.

Potom ubacite prvi CD-ROM, pokrenite apt-cdrom add, zatim ubacite drugi CD-ROM i pokrenite apt-cdrom add; zatim dvaput (ili triput?) pokrenite apt-get dist-upgrade -u.


3.2 Korištenje dselecta

Ovo poglavlje pretpostavlja da već imate neko znanje o dselectu. Ipak, sustav koji nadograđujete ste sami instalirali, zar ne? Pogledajte dselect Dokumentaciju za početnike u slučaju da morate osvježiti pamćenje.

Prvi korak u korištenju dselecta je izbor metode pristupa. Više informacija o pristupnim metodama i njihovom izabiranju sadrži gorespomenuta dselect dokumentacija.

dselectova metoda pristupa `apt' je trenutno najbrža. Pakete instalira i konfigurira u pravom poretku, pa su sve zavisnosti zadovoljene pri otpakiravanju paketa, čineći tako drugi prolaz nepotrebnim. Međutim, metoda pristupa `apt' još ne zna ispravno postupati s višestrukim CD-ima. Ako je neki paket na vašem sustavu tako potrgan da se apt-get upgrade ne može koristiti, metoda pristupa `apt' će također podbaciti.

Metoda pristupa `mounted' najprije instalira i konfigurira sve pre-dependove, što smanjuje broj potrebnih instalacijskih prolaza. Metoda pristupa `mountable' također pokušava najprije instalirati i konfigurirati pre-dependove i relativno je brza. (Postoje neki poznati problemi u radu ovih metoda s predzavisnostima; u slučaju problema pokušajte koristiti metodu apt kako je opisano gore.)

Preporučena metoda pristupa za korištenje s višestrukim CD-ovima je metoda multi_cd. Kako biste koristili ovu metodu, najprije instalirajte dpkg-multicd pomoću:

     dpkg -i <točka_montiranja_CD-a>/dists/slink/main/binary-m68k/base/dpkg-multicd

ili

     apt-get install dpkg-multicd

O korištenju ove metode govore README.multicd na prvom CD-u i, nakon instalacije, /usr/doc/dpkg-multicd/readme.txt.gz.

hamm verzija metode pristupa `http' ne radi pravilno s pre-dependima; ne preporuča se. Ako se za nadogradnju koristi ta verzija dpkg-httpa, bit ćete pitani Abort automatic installation (Y/n)? za svaki pre-depend. Zbog buga u hammovom dpkg-httpu korisnik tada mora pritisnuti Ctrl-C umjesto Y i traženi paket instalirati ručno (dpkg -i). dselect bi onda trebalo pokrenuti ispočetka kako bi se našao sljedeći pre-depend. Kako bi uštedio vrijeme, korisnik može ručno instalirati ove slink pakete: libc6, libncurses4, libreadlineg2, libstdc++2.9, slang1 i libhtml-parser-perl.

Bez obzira na korištenu metodu pristupa, preporuča se najprije nadograditi postojeće pakete, a tek onda dodavati nove. U dselectu prvo pokrenite korake [A]ccess, [U]pdate i [S]elect. Čim uđete u [S]elect, odmah pritisnite `D' (shift-D), a zatim Enter. Vjerojatno će se prikazati zaslon za rješavanje konflikta/zavisnosti. Nakon rješavanja konflikata (obično je dovoljno samo pritisnuti Enter), pokrenite [I]nstall, a zatim [C]onfigure za jednostavno nadograđivanje svih instaliranih paketa. Nakon toga, ako želite, možete koristiti module [S]elect i [I]nstall za instaliranje dodatnih paketa.

Kada dpkg ili dselect nadograđuju mnogo paketa, obično je potrebno ponoviti korake [I]nstall i [C]onfigure nekoliko puta prije no što cijeli sustav bude podešen. Ovisno o izboru metode pristupa, može biti potrebno između prolaza ponoviti korak [U]pdate. Od pomoći može biti izlaženje iz dselecta i ponovo pokretanje baš prije koraka [U]pdate.


3.3 Opće opasnosti

Ne biste smjeli pokretati nadogradnju iz X sesije kojom upravlja xdm na stroju kojeg nadograđujete. xdm i xfs se pri nadogradnji zaustavljaju, pa biste završili s napola nadograđenim strojem kada bi se X odjednom ugasio. Ako je stroj konfiguriran za automatsko pokretanje X-a pri dizanju, to može biti teško srediti. Ako je X server kojeg koristite od nadograđivanog računala prima xfs font usluge, izgubit će vezu na font server kada se xfs zaustavi. To nije kobno, ali može biti neugodno. Ako niste sigurni upravlja li vašom X sesijom xdm, nadogradite stroj iz Linux virtualne konzole.

Ne biste smjeli obavljati nadogradnju preko udaljene telnet veze, osim ako najprije instalirate slink pakete netstd i telnetd. telnet veza će pući kada se obriše stari paket netstd, i nećete ju moći ponovo uspostaviti dok se ne instalira paket telnetd.


[ natrag ] [ Sadržaj ] [ dalje ]
Napomene izdanja za Debian GNU/Linux GNU/Linux 2.1 (Slink)
verzija 2.1.11, 28. 8. 1999.
Bob Hilliard hilliard@debian.org
Adam Di Carlo