Errata: Running Linux 2.2.x in slink

This page documents known problems with running the Linux 2.2.x kernel in Debian 2.1 (slink). It assumes that you are running a fully up-to-date slink system.

The slink release is certified and officially tested for use with the late 2.0.x Linux kernels. Since the freeze of Debian occurred before Linux 2.2's release, and the change of the kernel's major version number can introduce complex issues, it was decided to stick with the proven 2.0 line of kernels.

Debian releases, however, are not necessarily kernel version bound. You may run any kernel you wish in Debian. We simply can give no assurances, however, that everything will function properly. If you do decide to move up to the Linux 2.2 line, and experience problems with a package, you may have luck running the potato (Debian 2.2) version of that package.

There are many links below pointing to potato versions of packages. Note that if you install these packages on a stable machine, you may need to also install potato libraries or other packages dependencies. Notably, you'll probably have to upgrade your libc6 package. We suggest using apt-get for this purpose, which will get only the necessary packages when used correctly. However, be warned: while most users have no trouble running a stable/frozen mixed system, you may be bitten by transient bugs in potato.

The kernel-source-2.2.1 package is shipped in the distribution to aid users who want to run the Linux 2.2.x kernels. However, it is recommended that you check the standard kernel distribution sites, such as, for newer versions of the 2.2.x source tree and additional errata. There are known bugs in 2.2.1, and that version is known to have caused data corruption for some. You should get the patches for the newer 2.2 series kernel and apply them to the Linux kernel source tree.

Potentially Problematic Packages

Note that this list may be incomplete. Please submit a bug against if you find other problems not listed. Check the bug logs for the package in question as well as well; try to make sure that the problem was introduced in Linux 2.2.

procinfo will not run. The version from potato fixes this.
In Linux 2.2, ipautofw must be replaced by ipmasqadm and ipfwadm is replaced with ipchains. The potato netbase package contains a wrapper script, ipfwadm-wrapper, to ease the transition.

ifconfig won't show aliases interfaces, and under some circumstances, ipchains will silently fail to clear packet counters. Some routes built by the netbase init scripts will cause harmless warning messages.

All of these issues are solved in the potato version. If you do not wish to upgrade to potato, Debian 2.1-compatible packages have been made available.

The version of pcmcia-source in slink cannot be compiled with the 2.2 kernel. Fixed in the potato version.
Breaks under Linux 2.2; use the potato version.
The /etc/dhclient-script doesn't work with 2.2. The version from potato fixes this; note the package was renamed to just dhcp-client.
Version 2.0.1, in slink, is incompatible with the 2.2. kernels. Version 2.0.4 and up, which you can get from potato, will work for the 2.2 kernels, but not with the 2.0 kernels (a kernel patch for 2.0 is included in the potato version, however).
bootpc will not receive a reply unless the interface has already been configured. This has been fixed in the now-separate bootpc package in potato.
lsof needs a recompile to work with linux 2.2. Upgrade to the lsof package available from potato.
The accounting structure has changed in the 2.2 kernel, so if you are running acct and Linux 2.2, you'll need the version of the package from potato (which is incompatible with the 2.0 series kernels).
isdnutils 3.0 or greater in Debian should work with both 2.0 and 2.2 series kernels. This is only the case because the Debian package maintainer took special trouble to make sure this is the case. Other distributions may not be so lucky.
The slink diald package has problems creating routes dynamically in Linux 2.2. Upgrade to the version available in potato.
xosview will loop endlessly on Linux 2.2.2 and greater. Upgrade to the version available in potato.