Приложение A. Подготовка системы lenny к обновлению

Содержание

A.1. Обновление системы lenny
A.2. Проверка списка источников APT
A.3. Переход к использованию локалей с UTF-8

В этом приложении содержится информация о том, как перед обновлением до squeeze удостовериться, что вы можете устанавливать или обновлять пакеты lenny. Это может понадобиться в некоторых случаях.

A.1. Обновление системы lenny

В основном, это обновление ничем не отличается от всех предыдущих обновлений lenny, которые вы делали. Единственное отличие состоит в том, что сначала надо убедиться, что ваши списки пакетов всё ещё содержат ссылки на пакеты lenny, как описано в Раздел A.2, «Проверка списка источников APT».

Если вы обновляете систему с сервера-зеркала Debian, то автоматически будет выполнено обновление до последнего выпуска lenny.

A.2. Проверка списка источников APT

Если в одной или нескольких строках в вашем /etc/apt/sources.list есть ссылка на стабильный дистрибутив ('stable'), то вы уже «используете» squeeze. Если вы уже запустили apt-get update, то ещё не поздно всё отменить, просто выполнив инструкцию, приведённую ниже.

Если вы успели установить пакеты из squeeze, то особого смысла в установке пакетов из lenny уже нет. В этом случае вам следует решить — доводить до конца обновление или нет. Вернуться к использованию старых версий пакетов возможно, но эта процедура выходит за рамки данного документа.

Откройте файл /etc/apt/sources.list с помощью любого текстового редактора (имея привилегии root) и поищите в строках, начинающихся с deb http: или с deb ftp:, слово «stable». При нахождении, замените «stable» на «lenny».

Если вы нашли строки, начинающиеся с deb file:, то вам придётся самостоятельно проверить, какие пакеты хранятся в указанном каталоге — lenny или squeeze.

[Важно]Важно

Не исправляйте строки, начинающиеся с deb cdrom:. Если вы исправите такую строку, то вам придётся снова запускать apt-cdrom. Не беспокойтесь, если источник cdrom ссылается на нестабильный («unstable») дистрибутив. Как это ни странно, так и должно быть.

Если вы внесли какие-нибудь изменения, сохраните файл и выполните команду

# apt-get update

для обновления списка пакетов.

A.3. Переход к использованию локалей с UTF-8

Если вы работаете с локализованной версией системы и используемая локаль основана не на UTF-8, то настоятельно советуем задействовать в системе локаль с UTF-8. С недавних пор, стали возникать ошибки, которые проявляются только когда используется локаль не-UTF-8. Работа приложений для рабочего стола с этими устаревшими локалями поддерживается специфическими внутренними механизмами библиотек, и мы больше не можем предоставить полную поддержку пользователям, которые продолжают их использовать.

Для настройки локали в системе запустите dpkg-reconfigure locales. Выберите локаль с UTF-8 когда будет задан вопрос о системной локали по умолчанию. Также, посмотрите настройки локали пользователей и убедитесь, что в их окружении не включены старые локали.