Notas de Lançamento para Debian 9 (stretch), 64-bit little-endian PowerPC

O Projecto de Documentação Debian

Este documento é software livre; você pode redistribuí-lo e/ou modificá-lo sob os termos da GNU General Public License, versão 2, conforme publicada pela Free Software Foundation.

Este programa é distribuído na esperança de que seja útil, mas SEM QUALQUER GARANTIA; sem mesmo a garantia implícita de COMERCIABILIDADE ou ADEQUAÇÃO A UM PROPÓSITO PARTICULAR. Veja a GNU General Public License para mais detalhes.

Você deve ter recebido uma cópia da GNU General Public License juntamente com este programa; caso contrário, escreva para a Free Software Foundation, Inc.,51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

O texto de licença também pode também ser encontrado em http://www.gnu.org/licenses/gpl-2.0.html e /usr/share/common-licenses/GPL-2 em Debian.


Índice

1. Introdução
1.1. Relatar erros neste documento
1.2. Contribuir com relatórios de actualização
1.3. Fontes para este documento
2. O que há de novo em Debian 9
2.1. Arquitecturas suportadas
2.2. O que há de novo na distribuição?
2.2.1. CDs, DVDs e BDs
2.2.2. Segurança
2.2.3. MariaDB substitui MySQL
2.2.4. Melhorias no APT e no layout dos arquivos
2.2.5. Novo mirror deb.debian.org
2.2.6. Mudar para o GnuPG Moderno
2.2.7. Um novo arquivo para símbolos de debug
2.2.8. Novo método para nome de interfaces de rede
2.2.9. Notícias do Blend Debian Med
2.2.10. O servidor Xorg já não necessita de root
3. Sistema de Instalação
3.1. O que há de novo no sistema de instalação?
3.1.1. Maiores alterações
3.1.2. Instalação automatizada
4. Actualizações a partir de Debian 8 (jessie)
4.1. Preparar para a actualização
4.1.1. Salvaguardar quaisquer dados ou informação de configuração
4.1.2. Informar os utilizadores com antecedência
4.1.3. Preparar para desligar temporariamente os serviços
4.1.4. Preparar para recuperação
4.1.5. Preparar um ambiente seguro para a actualização
4.2. Verificar o estado do sistema
4.2.1. Rever as acções pendentes no gestor de pacotes
4.2.2. Desactivar o APT pinning
4.2.3. Verificar o estado dos pacotes
4.2.4. Secção de actualizações propostas (proposed-updates)
4.2.5. Fontes não oficiais
4.3. Preparar as fontes para o APT
4.3.1. Acrescentar fontes APT da Internet
4.3.2. Acrescentar fontes APT para um 'mirror' local
4.3.3. Acrescentar fontes APT a partir de meios ópticos
4.4. Actualizar pacotes
4.4.1. Gravar a sessão
4.4.2. Actualizar a lista de pacotes
4.4.3. Certificar-se que possui espaço suficiente para a actualização
4.4.4. Actualização mínima do sistema
4.4.5. Actualizar o sistema
4.5. Possíveis problemas durante a actualização
4.5.1. Dist-upgrade falha com Não pode executar a configuração imediata
4.5.2. Remoções esperadas
4.5.3. Conflitos ou Ciclos de Pré-Dependências
4.5.4. Conflitos de ficheiros
4.5.5. Alterações de configuração
4.5.6. Mudança de sessão para consola
4.6. Actualizar o seu kernel e pacotes relacionados
4.6.1. Instalar um meta-pacote do kernel
4.7. Preparar para o próximo lançamento
4.7.1. Purgar pacotes removidos
4.8. Pacotes obsoletos
4.8.1. Pacotes fictícios
5. Problemas a estar atento na stretch
5.1. Itens específicos de actualizações para Stretch
5.1.1. Já não é suportado a montagem tardia de /usr
5.1.2. O acesso FTP a mirrors Debian será removido
5.1.3. Pacotes relevantes obsoletos
5.1.4. Coisas a fazer após a actualização e antes de reiniciar
5.1.5. Os executáveis são agora compilados, por omissão, como executáveis de posição independente (PIE).
5.1.6. A maioria dos pacotes de compatibilidade LSB foram removidos
5.2. Limitações no suporte de segurança
5.2.1. Estado da segurança dos navegadores web
5.2.2. Falta de suporte de segurança para o ecossistema à roda de libv8 e Node.js
5.3. Problemas com pacotes específicos
5.3.1. Cifras antigas e o protocolo SSH1 estão desabilitados mo OpenSSH por defeito
5.3.2. Possíveis alterações não retro-compatíveis a APT
5.3.3. Os Desktops irão migrar para o driver Xorg libinput
5.3.4. Upstart foi removido
5.3.5. A ferramenta debhelper agora gera, por defeito, pacotes dbgsym
5.3.6. Alterações relacionadas com OpenSSL
5.3.7. As alterações em Perl podem afectar software de terceiros
5.3.8. Incompatibilidade PL/Perl
5.3.9. O pacote net-tools será depreciado em favor do iproute2
5.3.10. A opção de mount _netdev é recomendada ao utilizar dispositivos AoE (ATA over ethernet)
5.3.11. Avisos Unespaced ... in regex is deprecated, ... inofensivos durante a actualização
5.3.12. Migração da policy store de SELinux
6. Mais informação acerca de Debian
6.1. Leitura adicional
6.2. Procurar ajuda
6.2.1. Listas de mail
6.2.2. Internet Relay Chat (IRC)
6.3. Relatar erros
6.4. Contribuir para a Debian
A. Gerir o seu sistema jessie antes da actualização
A.1. Actualizar o seu sistema jessie
A.2. Verificar a sua lista de fontes
A.3. Remover ficheiros de configuração obsoletos
A.4. Actualizar locales antigos para UTF-8
B. Colaboradores para as Notas de Lançamento
Índice Remissivo
glossário