Capítulo 2. Las novedades de Debian 9

Tabla de contenidos

2.1. Arquitecturas soportadas
2.2. ¿Qué novedades hay en la distribución?
2.2.1. CDs, DVDs y BDs
2.2.2. Seguridad

The Wiki has more information about this topic.

2.1. Arquitecturas soportadas

Las siguientes son las arquitecturas oficialmente soportadas en Debian 9:

  • 32-bit PC (i386) and 64-bit PC (amd64)

  • 64-bit ARM (arm64)

  • ARM EABI (armel)

  • ARMv7 (EABI hard-float ABI, armhf)

  • MIPS (mips (big-endian) and mipsel (little-endian))

  • PowerPC (powerpc)

  • 64-bit little-endian PowerPC (ppc64el)

  • IBM System z (s390x)

Puede leer más acerca del estado y la información específica de las adaptaciones para su arquitectura en la página web de las adaptaciones de Debian.

2.2. ¿Qué novedades hay en la distribución?

 POR HACER: Asegúrate de actualizar los números en el fichero .ent
   usando el script changes-release.pl en ../

This new release of Debian again comes with a lot more software than its predecessor jessie; the distribution includes over 12253 new packages, for a total of over 43512 packages. Most of the software in the distribution has been updated: over 24573 software packages (this is 66% of all packages in jessie). Also, a significant number of packages (over 5441, 14% of the packages in jessie) have for various reasons been removed from the distribution. You will not see any updates for these packages and they will be marked as "obsolete" in package management front-ends; see Sección 4.8, “Paquetes obsoletos”.

Debian trae de nuevo con muchas aplicaciones de escritorio y entornos. Entre otros ahora incluye el entorno de escritorio GNOME 3.14, KDE 4.11, Xfce 4.10, y LXDE.

También se han actualizado las aplicaciones de productividad, incluyendo las suites de oficina:

  • LibreOffice se ha actualizado a la versión 4.3;

  • Calligra se ha actualizado a la versión 2.8;

  • GNUcash se ha actualizado a la versión 2.6;

  • GNUmeric se ha actualizado a la versión 1.12;

  • Abiword se ha actualizado a la versión 3.0.

Las actualizaciones de otras aplicaciones de escritorio incluyen la actualización a Evolution 3.12.

Esta versión, entre muchas otras cosas, incluye las siguientes actualizaciones:

PaqueteVersión en 8 (jessie)Versión en 9 (stretch)
Apache2.2.222.4.10
BIND Servidor DNS9.89.9
Courier MTA0.680.73
Dia0.97.20.97.3
Exim servidor de correo predeterminado4.804.84
La colección de compilador GNU como el compilador por omisión4.7 en PCs, 4.6 en otros sistemas4.9
La biblioteca de C de GNU2.132.19
lighttpd1.4.311.4.35
imagen del núcleo de Linuxserie 3.2serie 3.16
OpenLDAP2.4.312.4.40
OpenSSH6.0p16.7p1
Perl5.145.20
PHP5.45.6
Postfix MTA2.92.11
PostgreSQL9.19.4
Python 33.23.4
Samba3.64.1
 POR HACER: (JFS): ¿Listar otros servidores como RADIUS, de streaming, ...?

Debian es compatible con la versión 4.1 de los Estándares Base de Linux («Linux Standard Base», LSB), con una desviación explícita y específica de Debian de la especificación LSB 4.1: no se incluye Qt3.

2.2.1. CDs, DVDs y BDs

La distribución oficial de Debian se compone ahora de 9 a 10 DVDs binarios o de 75 a 85 CDs binarios (dependiendo de la arquitectura) y de 10 DVDs o 59 CDs de fuentes. Adicionalmente existe un DVD multi-arch, con un subconjunto de la distribución para las arquitecturas amd64 y i386, así como su código fuente. Debian también se distribuye en imágenes Blu-ray (BD, son 2 para cada una de las arquitecturas amd64 y i386, o 2 para el código fuente. Por razones de espacio, algunos paquetes muy grandes se han omitido de los CDs generados. Estos paquetes encajan mejor en los DVDs y BDs por lo que se incluyen allí.

2.2.2. Seguridad

En esta publicación se ha deshabilitado el soporte a versiones antiguas del protocolo «Secure Sockets Layer», en concreto SSLv3. Se han compliado o configurado muchas librerías criptográficas del sistema así como aplicaciones clientes y servidores de forma que el soporte a este protocolo ya no está disponible.

El núcleo de Linux incluye un mecanismo de seguridad que hace inútiles muchos ataques de enlaces simbólicos. Este mecanismo está habilitado en el núcleo distribuido en Debian por omisión. Las erratas asociadas al mal uso de directorios temporales como /tmp y que dejan de ser aprovechables con este mecanismo dejarán de tratarse como vulnerabilidades de seguridad. Si está utilizando un núcleo de Linux adaptado debería activar esta funcionalidad con la siguiente opción de «sysctl»:

echo 1 > /proc/sys/fs/protected_symlinks

En algunos casos raros es posible que se deje de dar soporte de seguridad a algún paquete que se distribuya en una publicación de Debia antes de que se deje de dar soporte a toda la distribución. En Jessie se incluye un nuevo paquete (debian-security-support) que mostrará avisos en el caso de que se tenga que dejar de dar soporte de forma prematura a algún paquete. Ese paquete también documenta aquellos paquetes para los que el soporte de seguridad está limitado. Por ello, se recomienda que instale el paquete debian-security-support en todos los sistemas en los que la seguridad sea importante.