Apêndice A. Gerenciando seu sistema wheezy antes da atualização

Índice

A.1. Atualizando seu sistema wheezy
A.2. Verificando sua lista de fontes (sources list)
A.3. Removendo arquivos de configuração obsoletos
A.4. Atualizar locales antigos para UTF-8

Este apêndice contém informações sobre como assegurar-se de que você consegue instalar ou atualizar pacotes do wheezy antes de atualizar para o jessie. Isso só será necessário em situações específicas.

A.1. Atualizando seu sistema wheezy

Basicamente, isso não é diferente de qualquer outra atualização do wheezy que você tenha feito. A única diferença é que você precisa ter certeza de que sua lista de pacotes ainda contém referências para o wheezy conforme explicado na Seção A.2, “Verificando sua lista de fontes (sources list)”.

Se você atualizar o seu sistema usando um espelho Debian, ele automaticamente atualizará para a última versão pontual do wheezy.

A.2. Verificando sua lista de fontes (sources list)

Se qualquer uma das linhas no seu arquivo /etc/apt/sources.list fizer referência a stable, você já está efetivamente usando o jessie. Isso pode não ser o que você quer se você não estiver pronto ainda para a atualização. Se você já executou apt-get update, você ainda pode voltar atrás sem problemas seguindo o procedimento abaixo.

Se você também já instalou pacotes do jessie, provavelmente não há razão para instalar pacotes do wheezy. Neste caso, você terá que decidir se quer continuar ou não. É possível rebaixar a versão (downgrade) dos pacotes, mas isso não é abordado neste documento.

Abra o arquivo /etc/apt/sources.list com seu editor favorito (como root) e verifique todas as linhas começando com deb http: ou deb ftp: para determinar se existe uma referência a stable. Se você encontrar qualquer uma, mude o stable para wheezy.

Se você possui linhas começando com deb file:, você mesmo terá que verificar se o local indicado contém um repositório do wheezy ou do jessie.

[Importante]Importante

Não mude nenhuma linha que comece com deb cdrom:. Fazer isso invalidaria a linha e você teria que executar o apt-cdrom novamente. Não se assuste se uma linha para uma fonte do tipo 'cdrom' apontar para unstable. Embora confuso, isso é normal.

Se você fizer quaisquer mudanças, salve o arquivo e execute

# apt-get update

para atualizar a lista de pacotes.

A.3. Removendo arquivos de configuração obsoletos

Antes de atualizar o seu sistema para jessie, é recomendado remover arquivos de configuração antigos (tais como arquvos *.dpkg-{new,old} em /etc, assim como o arquivo /etc/X11/XF86Config-4[6]) do sistema.

A.4. Atualizar locales antigos para UTF-8

Se o seu sistema está localizado e usando um locale que não é baseado em UTF-8 você deve fortemente considerar a mudança do seu sistema para utilizar locales do tipo UTF-8. No passado, existiram bugs[7] identificados que só se manifestavam ao utilizar um locale não-UTF-8. No ambiente de trabalho, tais locales antigos são suportados através de truques feitos no interior das bibliotecas, e nós não podemos prestar um bom suporte aos usuários que ainda os utilizem.

Para configurar os locales do seu sistema você pode executar dpkg-reconfigure locales. Certifique-se de selecionar um locale UTF-8 quando for perguntado sobre qual locale utilizar por padrão no sistema. Além disso, você deve rever as configurações do locale dos seus usuários e garantir que eles não tenham definições antigas em seus ambientes de configuração.



[6] Desde a versão 2:1.7.7-12, o xorg-server não lê mais o arquivo XF86Config-4. Veja também o bug #619177.

[7] No protetor de tela do GNOME, o uso de senhas com caracteres não-ASCII, suporte a pam_ldap, ou até mesmo a capacidade de desbloquear a tela pode não ser confiável quando não estiver usando UTF-8. O leitor de tela do GNOME é afetado pelo bug #599197. O gerenciador de arquivos Nautilus (e todos os programas baseados na glib, e provavelmente também todos os programas baseados na Qt) assume que os nomes de arquivos estão em UTF-8, enquanto o shell assume que eles estão na codificação atual do locale. No uso diário, nomes de arquivo não-ASCII são simplesmente inutilizáveis em tais configurações. Além disso, o leitor de tela gnome-orca (o qual permite que usuários com deficiência visual acessem o ambiente de trabalho GNOME) requer um locale UTF-8 desde o Squeeze; sob um conjunto de caracteres antigo, ele será incapaz de ler a informação da tela para elementos do ambiente de trabalho, tais como o Nautilus/Painel do GNOME ou o menu Alt-F1.