Debian Security Advisory

wget -- Improper handling of symlink permissions

Date Reported:
20 Feb 1999
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-1999-0402.
More information:
The version of wget in slink (2.1) and potato incorrectly attempts to chmod symlinks when invoked with the -N option. The version in hamm (Debian 2.0) is not affected.

Only the wget package in the unreleased Debian versions is affected. You can install wget_1.4.5-0.1 from the Debian 2.0 release, or wait for a fixed wget_1.5.3, which will be released shortly.