Debians sikkerhedsbulletin

DSA-016-3 wu-ftpd -- oprettelse af midlertidig fil og format-streng

Rapporteret den:
23. jan 2001
Berørte pakker:
wu-ftpd
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 2189, BugTraq-id 2296.
I Mitres CVE-ordbog: CVE-2001-0187.
Yderligere oplysninger:
Sikkerhedsfolk hos WireX har opdaget en fejl ved oprettelse af midlertidige filer og WU-FTPD-udviklerne har opdaget en mulig format-strengfejl i wu-ftpd. Begge kunne udnyttes af en fjernbruger, selvom der ikke pt. er nogen angreb.

Vi anbefaler at du omgående opgraderer din wu-ftpd-pakke.

Rettet i:

Debian 2.2 (potato)

Kildekode:
http://security.debian.org/dists/stable/updates/main/source/wu-ftpd_2.6.0.orig.tar.gz
http://security.debian.org/dists/stable/updates/main/source/wu-ftpd_2.6.0-5.2.dsc
http://security.debian.org/dists/stable/updates/main/source/wu-ftpd_2.6.0-5.2.diff.gz
alpha:
http://security.debian.org/dists/stable/updates/main/binary-alpha/wu-ftpd_2.6.0-5.2_alpha.deb
arm:
http://security.debian.org/dists/stable/updates/main/binary-arm/wu-ftpd_2.6.0-5.2_arm.deb
i386:
http://security.debian.org/dists/stable/updates/main/binary-i386/wu-ftpd_2.6.0-5.2.1_i386.deb
m68k:
http://security.debian.org/dists/stable/updates/main/binary-m68k/wu-ftpd_2.6.0-5.2_m68k.deb
powerpc:
http://security.debian.org/dists/stable/updates/main/binary-powerpc/wu-ftpd_2.6.0-5.2_powerpc.deb
sparc:
http://security.debian.org/dists/stable/updates/main/binary-sparc/wu-ftpd_2.6.0-5.2_sparc.deb