Debian Security Advisory

DSA-059-1 man-db -- symlink attack

Date Reported:
12 Jun 2001
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 2720, BugTraq ID 2815.
In Mitre's CVE dictionary: CVE-2001-1331.
More information:
Luki R. reported a bug in man-db: it did not handle nested calls of drop_effective_privs() and regain_effective_privs() correctly which would cause it to regain privileges too early. This could be abused to make man create files as user man.

This has been fixed in version 2.3.16-4, and we recommend that you upgrade your man-db package immediately. If you use suidmanager you can also use that to make sure man and mandb are not installed suid which protects you from this problem. This can be done with the following commands:

   suidregister /usr/lib/man-db/man root root 0755
   suidregister /usr/lib/man-db/mandb root root 0755

Of course even when using suidmanager an upgrade is still strongly recommended.

Fixed in:

Debian GNU/Linux 2.2 (potato)

Intel IA-32:
Motorola 680x0:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.