Debian Security Advisory

DSA-080-1 htdig -- unauthorized gathering of data

Date Reported:
17 Oct 2001
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2001-0834.
More information:
Nergal reported a vulnerability in the htsearch program which is distributed as part of the ht://Dig package, an indexing and searching system for small domains or intranets. Using former versions it was able to pass the parameter -c to the cgi program in order to use a different configuration file.

A malicious user could point htsearch to a file like /dev/zero and let the server run in an endless loop, trying to read config parameters. If the user has write permission on the server they can point the program to it and retrieve any file readable by the webserver user id.

This problem has been fixed in version 3.1.5-2.0potato.1 for Debian GNU/Linux 2.2.

We recommend that you upgrade your htdig package immediately.

Fixed in:

Debian GNU/Linux 2.2 (potato)

Architecture-independent component:
Intel ia32:
Motorola 680x0:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.