Debian Security Advisory

DSA-098-1 libgtop -- format string vulnerability and buffer overflow

Date Reported:
09 Jan 2002
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2001-0927, CVE-2001-0928.
More information:

Two different problems where found in libgtop-daemon:

  • The laboratory intexxia found a format string problem in the logging code from libgtop_daemon. There were two logging functions which are called when authorizing a client which could be exploited by a remote user.
  • Flavio Veloso found a buffer overflow in the function that authorizes clients

Since libgtop_daemon runs as user nobody both bugs could be used to gain access as the nobody user to a system running libgtop_daemon.

Both problems have been fixed in version 1.0.6-1.1 and we recommend you upgrade your libgtop-daemon package immediately.

Fixed in:

Debian GNU/Linux 2.2 (potato)

Intel IA-32:
Motorola 680x0:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.