Debian Security Advisory

DSA-131-1 apache -- remote DoS / exploit

Date Reported:
19 Jun 2002
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 5033.
In Mitre's CVE dictionary: CVE-2002-0392.
CERT's vulnerabilities, advisories and incident notes: CA-2002-17, VU#944335.
More information:

Mark Litchfield found a denial of service attack in the Apache web-server. While investigating the problem the Apache Software Foundation discovered that the code for handling invalid requests which use chunked encoding also might allow arbitrary code execution on 64 bit architectures.

This has been fixed in version 1.3.9-14.1 of the Debian apache package, as well as upstream versions 1.3.26 and 2.0.37. We strongly recommend that you upgrade your apache package immediately.

The package upgrade does not restart the apache server automatically, this will have to be done manually. Please make sure your configuration is correct ("apachectl configtest" will verify that for you) and restart it using "/etc/init.d/apache restart"

Fixed in:

Debian GNU/Linux 2.2 (potato)

Architecture-independent component:
Intel IA-32:
Motorola 680x0:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.