Debian Security Advisory

DSA-140-2 libpng -- buffer overflow

Date Reported:
05 Aug 2002
Affected Packages:
libpng, libpng3
Security database references:
In Mitre's CVE dictionary: CVE-2002-0660, CVE-2002-0728.
More information:

Developers of the PNG library have fixed a buffer overflow in the progressive reader when the PNG datastream contains more IDAT data than indicated by the IHDR chunk. Such deliberately malformed datastreams would crash applications which could potentially allow an attacker to execute malicious code. Programs such as Galeon, Konqueror and various others make use of these libraries.

In addition to that, the packages below fix another potential buffer overflow. The PNG libraries implement a safety margin which is also included in a newer upstream release. Thanks to Glenn Randers-Pehrson for informing us.

To find out which packages depend on this library, you may want to execute the following commands:

    apt-cache showpkg libpng2
    apt-cache showpkg libpng3

This problem has been fixed in version 1.0.12-3.woody.2 of libpng and version 1.2.1-1.1.woody.2 of libpng3 for the current stable distribution (woody) and in version 1.0.12-4 of libpng and version 1.2.1-2 of libpng3 for the unstable distribution (sid). The potato release of Debian does not seem to be vulnerable.

We recommend that you upgrade your libpng packages immediately and restart programs and daemons that link to these libraries and read external data, such as web browsers.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
HP Precision:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.