Säkerhetsbulletin från Debian

DSA-156-1 epic4-script-light -- exekvering av godtyckliga skript

Rapporterat den:
2002-08-22
Berörda paket:
epic4-script-light
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 5555.
I Mitres CVE-förteckning: CVE-2002-0984.
Ytterligare information:

Samtliga versioner av EPIC-skriptet Light tidigare än 2.7.30p5 (på 2.7-grenen) samt tidigare än 2.8pre10 (på 2.8-grenen) är sårbara för ett fel som kan utnyttjas utifrån, vilket kan leda till nästan godtycklig exekvering av kod.

Detta problem har rättats i version 2.7.30p5-1.1 för den nuvarande stabila utgåvan (Woody) samt i version 2.7.30p5-2 för den instabila utgåvan (Sid). Den gamla stabila utgåvan (Potato) påverkas inte, eftersom den inte innehåller Light-paketet.

Vi rekommenderar att ni uppgraderar ert epic4-script-light-paket och startar om era irc-klienter.

Rättat i:

Debian GNU/Linux 3.0 (woody)

Källkod:
http://security.debian.org/pool/updates/main/e/epic4-script-light/epic4-script-light_2.7.30p5-1.1.dsc
http://security.debian.org/pool/updates/main/e/epic4-script-light/epic4-script-light_2.7.30p5-1.1.diff.gz
http://security.debian.org/pool/updates/main/e/epic4-script-light/epic4-script-light_2.7.30p5.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/e/epic4-script-light/epic4-script-light_2.7.30p5-1.1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.