Aviso de seguridad de Debian

DSA-157-1 irssi-text -- denegación de servicio

Fecha del informe:
23 de ago de 2002
Paquetes afectados:
irssi-text
Vulnerable:
Referencias a bases de datos de seguridad:
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 5055.
En el diccionario CVE de Mitre: CVE-2002-0983.
Información adicional:

El cliente de IRC irssi es vulnerable a una condición de denegación de servicio. El problema ocurre cuando un usuario intenta unirse a un canal que tiene una descripción del tema demasiado larga. Cuando se añade una cierta cadena al tema, irssi cae.

Este problema ha sido corregido en la versión 0.8.4-3.1 para la distribución estable actual (woody) y en la versión 0.8.5-2 para la distribución inestable (sid). La distribución estable anterior (potato) no se ve afectada porque las porciones de código afectadas no están presentes. Lo mismo se aplica a irssi-gnome e irssi-gtk, que no parecen verse afectados.

Le recomendamos que actualice el paquete irssi-text.

Arreglado en:

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1.dsc
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1.diff.gz
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_ia64.deb
HP Precision:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_sparc.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.