Alerta de Segurança Debian

DSA-157-1 irssi-text -- negação de serviço

Data do Alerta:
23 Ago 2002
Pacotes Afetados:
irssi-text
Vulnerável:
Sim
Referência à base de dados de segurança:
Na base de dados do BugTraq (na SecurityFocus): ID BugTraq 5055.
No dicionário CVE do Mitre: CVE-2002-0983.
Informações adicionais:

O cliente de IRC irssi é vulnerável a uma condição de negação de serviço. O problema ocorre quando um usuário tenta entrar em um canal que têm um tópico longo. Quando uma certa string está presente no tópico, o irssi irá travar.

O problema foi corrigido na versão 0.8.4-3.1 para a atual distribuição estável (woody) e na versão 0.8.5-2 para a distribuição instável (sid). A antiga distribuição estável (potato) não foi afetada, uma vez que os portes correspondentes do código não estão presentes. O mesmo se aplica ao irssi-gnome e o irssi-gtk, que parecem não ter sido afetados.

Nós recomendamos que você atualize seu pacote irssi-text.

Corrigido em:

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1.dsc
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1.diff.gz
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_ia64.deb
HP Precision:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/i/irssi-text/irssi-text_0.8.4-3.1_sparc.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.