Debian Security Advisory

DSA-169-1 htcheck -- cross site scripting

Date Reported:
25 Sep 2002
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2002-1195.
More information:

Ulf Härnhammar discovered a problem in ht://Check's PHP interface. The PHP interface displays information unchecked which was gathered from crawled external web servers. This could lead into a cross site scripting attack if somebody has control over the server responses of a remote web server which is crawled by ht://Check.

This problem has been fixed in version 1.1-1.1 for the current stable distribution (woody) and in version 1.1-1.2 for the unstable release (sid). The old stable release (potato) does not contain the htcheck package.

We recommend that you upgrade your htcheck package immediately.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
HP Precision:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.