Bulletin d'alerte Debian

DSA-188-1 apache-ssl -- Plusieurs failles

Date du rapport :
5 novembre 2002
Paquets concernés :
apache-ssl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 5847, Identifiant BugTraq 5884, Identifiant BugTraq 5887, Identifiant BugTraq 5995.
Dans le dictionnaire CVE du Mitre : CVE-2002-0839, CVE-2002-0840, CVE-2002-0843, CVE-2001-0131, CVE-2002-1233.
Plus de précisions :

Selon David Wagner, iDEFENSE et le Projet Apache HTTP Server, plusieurs failles exploitables à distance ont été trouvées dans le paquet Apache, un serveur web très répandu. Une grande partie du code est identique dans les paquets Apache et Apache-SSL. Donc il en est de même avec les failles. Ces vulnérabilités permettraient à un attaquant de mettre hors service le serveur, d'exécuter une attaque via les scripts utilisés ou bien de voler des témoins (cookie) des autres utilisateurs du site web. Les failles de htdigest, htpasswd et ApacheBench, autres programmes inclus de base, peuvent être exploitées lors d'un appel CGI. De plus, la création de fichier temporaire non sécurisée dans htdigest et htpasswd peut aussi être exploitée localement. Le projet Common Vulnerabilities and Exposures (CVE) a identifié les failles suivantes :

  1. CAN-2002-0839 : Une faille existe sur les plates-formes utilisant les afficheurs basés sur la mémoire partagée à la System V. Cette faille permet à un attaquant qui peut avoir accès à l'UID d'Apache d'exploiter le format de cet afficheur et d'envoyer un signal à n'importe quel processus en tant que root ou de causer un déni de service ;
  2. CAN-2002-0840 : Apache est susceptible d'être vulnérable à une attaque sur les éléments dynamiques de la page 404 par défaut de n'importe quel serveur web hébergé par un domaine qui autorise la résolution de DNS avec des caractères joker ;
  3. CAN-2002-0843 : Il y a quelques débordements de mémoire dans l'utilitaire ApacheBench (ab) qui pourraient être utilisé par un serveur malveillant ;
  4. CAN-2002-1233 : Une condition d'exécution dans les programmes htpasswd et htdigest permet à un utilisateur local de lire voire de modifier le contenu d'un fichier de mots de passe ou facilement créer et écraser des fichiers appartenant à la personne qui fait tourner le programme htpasswd (ou htdigest respectivement). (les fichiers binaires ne sont pas inclus dans le paquet apache-ssl) ;
  5. CAN-2001-0131 : htpasswd et htdigest dans Apache 2.0a9, 1.3.14 et autres permettent aux utilisateurs locaux d'écraser des fichiers de manière arbitraire par une attaque à base de liens symboliques.

    Ceci est la même faille que celle de CAN-2002-1233, qui a déjà été corrigée dans Potato mais elle fut perdue et donc jamais appliquée dans le source original ;

  6. NO-CAN : Plusieurs débordements de tampon ont été trouvé dans l'utilitaire ApacheBench (ab) qui pourraient être exploités par un serveur distant en renvoyant des chaînes de caractère très longues (les paquets binaires ne sont pas fournis avec apache-ssl cependant).

Ces problèmes ont été corrigés dans la version 1.3.26.1+1.48-0woody3 pour l'actuelle distribution stable (Woody) et dans celle 1.3.9.13-4.2 pour l'ancienne distribution stable (Potato). Les paquets corrigés pour la distribution instable (Sid) seront bientôt prêts.

Nous recommandons de mettre à jour votre paquet Apache-SSL immédiatement.

Corrigé dans :

Debian GNU/Linux 2.2 (potato)

Source :
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2.dsc
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2.diff.gz
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2_i386.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2_m68k.deb
PowerPC:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2_powerpc.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.9.13-4.2_sparc.deb

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3.dsc
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3.diff.gz
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_ia64.deb
HP Precision:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/a/apache-ssl/apache-ssl_1.3.26.1+1.48-0woody3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.