Debians sikkerhedsbulletin

DSA-189-1 luxman -- lokal root-udnyttelse

Rapporteret den:
6. nov 2002
Berørte pakker:
luxman
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2002-1245.
Yderligere oplysninger:

iDEFENSE rapporterer om en sårbarhed i LuxMan, et labyrintspil til GNU/Linux svarende til PacMan-spillet. Udnyttes sårbarheden med succes, kan en lokal angriber få læse- og skriveadgang til hukommelsen, hvilket fører til en lokal root-udnyttelse på mange forskellige måder, eksempelvis scanning af filen efter dele af den primære adgangskodefil og tilpasning af kernehukommelse til omdirigering af systemkald.

Dette problem er rettet i version 0.41-17.1 i den aktuelle stabile distribution (woody) og i version 0.41-19 i den ustabile distribution (sid). Den gamle stabile distribution (potato) er ikke påvirket, da den ikke indeholder en luxman-pakke.

Vi anbefaler at du omgående opgraderer din luxman-pakke.

Rettet i:

Debian GNU/Linux 3.0 (woody)

Kildekode:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.1.dsc
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.1.diff.gz
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.1_i386.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.