Debian-Sicherheitsankündigung

DSA-192-1 html2ps -- Beliebige Code-Ausführung

Datum des Berichts:
08. Nov 2002
Betroffene Pakete:
html2ps
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 6079.
In Mitres CVE-Verzeichnis: CVE-2002-1275.
Weitere Informationen:

Das SuSE-Sicherheits-Team hat eine Verwundbarkeit in html2ps entdeckt, einem HTML nach PostScript Konvertier-Programm, das Dateien unsicher basierend auf ungesäuberten Eingaben öffnet. Dieses Problem kann ausgenutzt werden, wenn html2ps als Filter in lprng installiert ist und der Angreifer zuvor Zugriff auf das lp-Konto erlangt hat.

Diese Probleme wurden in Version 1.0b3-1.1 für die aktuelle stable Distribution (Woody), in Version 1.0b1-8.1 für die alte stable Distribution (Potato) und in Version 1.0b3-2 für die unstable Distribution (Sid) behoben.

Wir empfehlen Ihnen, Ihr html2ps-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 2.2 (potato)

Quellcode:
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b1-8.2.dsc
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b1-8.2.diff.gz
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b1.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b1-8.2_all.deb

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b3-1.2.dsc
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b3-1.2.diff.gz
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b3.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/h/html2ps/html2ps_1.0b3-1.2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.

MD5-Prüfsummen der aufgezählten Dateien stehen in der überarbeiteten Sicherheitsankündigung zur Verfügung.