Aviso de seguridad de Debian

DSA-199-1 mhonarc -- scripts a través del sitio

Fecha del informe:
19 de nov de 2002
Paquetes afectados:
mhonarc
Vulnerable:
Referencias a bases de datos de seguridad:
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 6204.
En el diccionario CVE de Mitre: CVE-2002-1307.
Información adicional:

Steven Christey descubrió una vulnerabilidad de scripts a través del sitio en mhonarc, un conversor de correo a HTML. Unas cabeceras de mensaje modificadas adecuadamente podían introducir scripts a través del sitio si mhonarc está configurado para mostrar todas las líneas de cabecera de la web. Sin embargo, a menudo es útil restringir las líneas de cabecera mostradas en A, De y Asunto, en cuyo caso la vulnerabilidad no se puede explotar.

Estos problemas se han corregido en la versión 2.5.2-1.2 para la distribución estable actual (woody), en la versión 2.4.4-1.2 para la distribución estable anterior (potato) y en la versión 2.5.13-1 para la distribución inestable (sid).

Le recomendamos que actualice el paquete mhonarc.

Arreglado en:

Debian GNU/Linux 2.2 (potato)

Fuentes:
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4-1.2.dsc
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4-1.2.diff.gz
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4-1.2_all.deb

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2-1.2.dsc
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2-1.2.diff.gz
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2-1.2_all.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.