Bulletin d'alerte Debian

DSA-199-1 mhonarc -- Faille sur les éléments dynamiques

Date du rapport :
19 novembre 2002
Paquets concernés :
mhonarc
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 6204.
Dans le dictionnaire CVE du Mitre : CVE-2002-1307.
Plus de précisions :

Steven Christey a découvert une faille sur les éléments dynamiques de mhonarc, un convertisseur courriel vers HTML. Des en-têtes de message soigneusement conçus peuvent introduire une attaque par les scripts si mhonarc est configuré pour afficher toutes les lignes d'en-tête sur le web. Cependant, il est souvent utile de réduire l'affichage aux lignes To, From et Subject, cas dans lequel la faille n'est pas exploitable.

Ce problème a été fixé dans la version 2.5.2-1.2 pour l'actuelle distribution stable (Woody), dans la version 2.4.4-1.2 pour l'ancienne distribution stable (Potato) et dans la version 2.5.13-1 pour la distribution instable (Sid).

Nous vous recommandons de mettre à jour votre paquet mhonarc.

Corrigé dans :

Debian GNU/Linux 2.2 (potato)

Source :
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4-1.2.dsc
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4-1.2.diff.gz
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.4.4-1.2_all.deb

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2-1.2.dsc
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2-1.2.diff.gz
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/m/mhonarc/mhonarc_2.5.2-1.2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.