Alerta de Segurança Debian

DSA-205-1 gtetrinet -- buffer overflow

Data do Alerta:
10 Dez 2002
Pacotes Afetados:
gtetrinet
Vulnerável:
Sim
Referência à base de dados de segurança:
Nenhuma outra base de dados externa de referências de segurança está disponível atualmente.
Informações adicionais:

Steve Kemp e James Antill encontraram vários buffer overflows no pacote gtetrinet (um jogo multiusuário semelhante ao tetris), distribuído no Debian GNU/Linux 3.0, que pode ser utilizado por um servidor malicioso.

Este problema foi corrigido na versão 0.4.4 do autor e lançado no pacote Debian 0.4.1-9woody1.1.

Corrigido em:

Debian GNU/Linux 2.2 (potato)

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1.dsc
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.dsc
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.diff.gz
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1.diff.gz
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1.orig.tar.gz
alpha (DEC Alpha):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_alpha.deb
arm (ARM):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_arm.deb
hppa (HP PA RISC):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_hppa.deb
i386 (Intel ia32):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_i386.deb
ia64 (Intel ia64):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_ia64.deb
m68k (Motorola Mc680x0):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_m68k.deb
mips (MIPS (Big Endian)):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_mips.deb
mipsel (MIPS (Little Endian)):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_mipsel.deb
powerpc (PowerPC):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_powerpc.deb
s390 (IBM S/390):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_s390.deb
sparc (Sun SPARC/UltraSPARC):
http://security.debian.org/pool/updates/main/g/gtetrinet/gtetrinet_0.4.1-9woody1.1_sparc.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.