Debian-Sicherheitsankündigung

DSA-244-1 noffle -- Pufferüberläufe

Datum des Berichts:
27. Jan 2003
Betroffene Pakete:
noffle
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2003-0037.
Weitere Informationen:

Dan Jacobson bemerkte ein Problem in noffle, einem Offline-News-Server, das zu einem Segmentation-Fault führt. Es ist noch nicht klar, ob dieses Problem ausgenutzt werden kann. Falls es dies jedoch ist, könnte ein entfernter Angreifer willkürliche Code-Ausführung mit dem Benutzer auslösen, der noffle ausführt, vermutlich news.

Für die stable Distribution (Woody) wurde dieses Problem in Version 1.0.1-1.1 behoben.

Die alte stable Distribution (Potato) enthält kein noffle-Paket.

Für die unstable Distribution (Sid) wurde dieses Problem in Version 1.1.2-1 behoben.

Wir empfehlen Ihnen, Ihr noffle-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1.dsc
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1.diff.gz
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.