Bulletin d'alerte Debian

DSA-244-1 noffle -- Débordements de tampon

Date du rapport :
27 janvier 2003
Paquets concernés :
noffle
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2003-0037.
Plus de précisions :

Dan Jacobson a relevé un problème dans noffle, un serveur de news pour la consultation hors-ligne, qui a pour conséquence une violation de la mémoire (segmentation fault). Il n'est pas clairement établi que ce problème puisse être exploité. Cependant, si c'est le cas, un attaquant distant pourrait faire exécuter un code arbitraire par l'identifiant de l'utilisateur qui appelle noffle, probablement l'utilisateur news.

Pour la distribution stable (Woody), ce problème a été corrigé dans la version 1.0.1-1.1.

L'ancienne distribution stable (Potato) ne contient pas le paquet noffle.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 1.1.2-1.

Nous vous recommandons de mettre à jour votre paquet noffle.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1.dsc
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1.diff.gz
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/n/noffle/noffle_1.0.1-1.1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.