Alerta de Segurança Debian

DSA-251-1 w3m -- quota HTML faltando

Data do Alerta:
14 Fev 2003
Pacotes Afetados:
w3m, w3m-ssl
Vulnerável:
Sim
Referência à base de dados de segurança:
No dicionário CVE do Mitre: CVE-2002-1335, CVE-2002-1348.
Informações adicionais:

Hironori Sakamoto, um dos desenvolvedores do w3m, encontrou duas vulnerabilidades relacionadas a segurança no programa w3w e associados. O navegador w3m não escapa adequadamente tags HTML no conteúdo de frames e atributos img alt. Um frame HTML malicioso ou atributo img alt pode enganar um usuário para enviar seus cookies locais que são usados para configuração. A informação não é enviada automaticamente.

Na atual distribuição estável (woody), este problema foi corrigido na versão 0.3-2.4.

A antiga distribuição estável (potato) não é afetada por este problema.

Na distribuição instável (sid), este problema foi corrigido na versão 0.3.2.2-1 e superior.

Nós recomendamos que você atualize seus pacotes w3m e w3m-ssl.

Corrigido em:

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4.dsc
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4.diff.gz
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3.orig.tar.gz
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4.dsc
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4.diff.gz
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_alpha.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_alpha.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_arm.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_arm.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_i386.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_i386.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_i386.deb
HPPA:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_hppa.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_hppa.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_m68k.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_m68k.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_mips.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_mips.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_mipsel.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_mipsel.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_powerpc.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_powerpc.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_s390.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_s390.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/w/w3m/w3m_0.3-2.4_sparc.deb
http://security.debian.org/pool/updates/main/w/w3m/w3m-img_0.3-2.4_sparc.deb
http://security.debian.org/pool/updates/main/w/w3m-ssl/w3m-ssl_0.3-2.4_sparc.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.