Bulletin d'alerte Debian

DSA-264-1 lxr -- Manque de protection dans le nom de fichier

Date du rapport :
19 mars 2003
Paquets concernés :
lxr
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2003-0156.
Plus de précisions :

Les développeurs de lxr, un outil généraliste de références croisées hypertextes, ont été alertés qu'une vulnérabilité permettait à un assaillant distant de lire n'importe quels fichiers se trouvant sur la machine hôte en utilisant l'utilisateur www-data. Cela peut révéler à la vue de tous des fichiers qui ne sont pas sensés être publiés.

Pour la distribution stable (Woody), ce problème a été corrigé dans la version 0.3-3.

L'ancienne distribution stable (Potato) n'est pas concernée étant donné qu'elle n'inclut pas le paquet lxr.

Pour la distribution instable (Sid) ce problème a été corrigé dans la version 0.3-4.

Nous vous recommandons de mettre à jour votre paquet lxr.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3.dsc
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3.diff.gz
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.