Debian セキュリティ勧告

DSA-264-1 lxr -- ファイル名のサニタイズの抜け

報告日時:
2003-03-19
影響を受けるパッケージ:
lxr
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2003-0156.
詳細:

lxr (汎用ハイパーテキストクロスリファレンスツール) の 上流の開発者により、リモートの攻撃者が www-data 権限で ホストシステム上の任意のファイルを読むことができるという 脆弱性があるという警告が出されました。 この脆弱性により、公開する意図のないローカルのファイルが 曝露されてしまいます。

現安定版 (stable)(woody) では、この問題はバージョン 0.3-3 で修正されています。

旧安定版 (potato) は、lxr パッケージを収録していないので、 この問題による影響はありません。

不安定版 (unstable)(sid) では、この問題はバージョン 0.3-4 で修正されています。

lxr パッケージをアップグレードすることをお勧めします。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3.dsc
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3.diff.gz
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lxr/lxr_0.3-3_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。