Debian Security Advisory

DSA-277-1 apcupsd -- buffer overflows, format string

Date Reported:
03 Apr 2003
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 7200.
In Mitre's CVE dictionary: CVE-2003-0098, CVE-2003-0099.
More information:

The controlling and management daemon apcupsd for APC's Unbreakable Power Supplies is vulnerable to several buffer overflows and format string attacks. These bugs can be exploited remotely by an attacker to gain root access to the machine apcupsd is running on.

For the stable distribution (woody) this problem has been fixed in version 3.8.5-1.1.1.

For the old stable distribution (potato) this problem does not seem to exist.

For the unstable distribution (sid) this problem has been fixed in version 3.8.5-1.2.

We recommend that you upgrade your apcupsd packages immediately.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.