Alerta de Segurança Debian

DSA-286-1 gs-common -- arquivo temporário inseguro

Data do Alerta:
14 Abr 2003
Pacotes Afetados:
gs-common
Vulnerável:
Sim
Referência à base de dados de segurança:
Na base de dados do BugTraq (na SecurityFocus): ID BugTraq 7337.
No dicionário CVE do Mitre: CVE-2003-0207.
Informações adicionais:

Paul Szabo descobriu uma criação insegura de arquivos temporários no ps2epsi, um script que é distribuído como parte do gs-common que contém arquivos comuns para diferentes versões do Ghostscript. O ps2epsi usa um arquivo temporário no processo de invocar o ghostscript. Este arquivo é criado de uma forma insegura, que pode permitir que um atacante local sobreescreva arquivos que tem como dono o usuário que chama o ps2epsi.

Na atual distribuição estável (woody), este problema foi corrigido na versão 0.3.3.0woody1.

A antiga distribuição estável (potato) não é afetada por este problema.

Na distribuição instável (sid), este problema foi corrigido na versão 0.3.3.1.

Nós recomendamos que você atualize seus pacotes gs-common.

Corrigido em:

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/g/gs-common/gs-common_0.3.3.0woody1.dsc
http://security.debian.org/pool/updates/main/g/gs-common/gs-common_0.3.3.0woody1.tar.gz
Componente independente de arquitetura:
http://security.debian.org/pool/updates/main/g/gs-common/gs-common_0.3.3.0woody1_all.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.