Debian Security Advisory

DSA-313-1 ethereal -- buffer overflows, integer overflows

Date Reported:
11 Jun 2003
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 7493, BugTraq ID 7494, BugTraq ID 7495.
In Mitre's CVE dictionary: CVE-2003-0356, CVE-2003-0357.
More information:

Timo Sirainen discovered several vulnerabilities in ethereal, a network traffic analyzer. These include one-byte buffer overflows in the AIM, GIOP Gryphon, OSPF, PPTP, Quake, Quake2, Quake3, Rsync, SMB, SMPP, and TSP dissectors, and integer overflows in the Mount and PPP dissectors.

For the stable distribution (woody) these problems have been fixed in version 0.9.4-1woody4.

The old stable distribution (potato) does not appear to contain these vulnerabilities.

For the unstable distribution (sid) these problems are fixed in version 0.9.12-1.

We recommend that you update your ethereal package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.