Bulletin d'alerte Debian

DSA-327-1 xbl -- Dépassements de tampon

Date du rapport :
19 juin 2003
Paquets concernés :
xbl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 7989.
Dans le dictionnaire CVE du Mitre : CVE-2003-0451.
Plus de précisions :

Steve Kemp a découvert plusieurs dépassements de tampon dans xbl, un jeu, qui peuvent être déclenchés par des arguments trop longs dans la ligne de commande. Cette faille de sécurité pouvait être exploitée par un attaquant local pour obtenir les privilèges du groupe games.

Pour la distribution stable (Woody), ce problème a été corrigé dans la version 1.0k-3woody1.

Pour l'ancienne distribution stable (Potato), ce problème a été corrigé dans la version 1.0i-7potato1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 1.0k-5.

Nous vous recommandons de mettre à jour votre paquet xbl.

Corrigé dans :

Debian GNU/Linux 2.2 (potato)

Source :
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1.dsc
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1.diff.gz
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1_i386.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1_m68k.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1_powerpc.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0i-7potato1_sparc.deb

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1.dsc
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1.diff.gz
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xbl/xbl_1.0k-3woody1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.