Debian Security Advisory

DSA-346-1 phpsysinfo -- directory traversal

Date Reported:
08 Jul 2003
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 7275, BugTraq ID 7286.
In Mitre's CVE dictionary: CVE-2003-0536.
More information:

Albert Puigsech Galicia reported that phpsysinfo, a web-based program to display status information about the system, contains two vulnerabilities which could allow local files to be read, or arbitrary PHP code to be executed, under the privileges of the web server process (usually www-data). These vulnerabilities require access to a writable directory on the system in order to be exploited.

For the stable distribution (woody) this problem has been fixed in version 2.0-3woody1.

For the unstable distribution (sid) this problem will be fixed soon. See Debian bug #200543.

We recommend that you update your phpsysinfo package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.