Säkerhetsbulletin från Debian

DSA-346-1 phpsysinfo -- katalogtraversering

Rapporterat den:
2003-07-08
Berörda paket:
phpsysinfo
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 7275, BugTraq-id 7286.
I Mitres CVE-förteckning: CVE-2003-0536.
Ytterligare information:

Albert Puigsech Galicia ripe@7a69ezine.org rapporterade att phpsysinfo, ett webbaserat program som visar statusinformation för systemet, innehåller två sårbarheter som gör det möjligt att läsa lokala filer eller exekvera godtycklig PHP-kod med webbserverprocessens privilegier (vanligtvis www-data). Dessa sårbarheter kräver tillgång till en skrivbar katalog på systemet för att kunna utnyttjas.

För den stabila utgåvan (Woody) har detta problem rättats i version 2.0-3woody1.

För den instabila utgåvan (Sid) kommer detta problem rättas inom kort. Se Debians felrapport 200543.

Vi rekommenderar att ni uppgraderar ert phpsysinfo-paket.

Rättat i:

Debian GNU/Linux 3.0 (woody)

Källkod:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody1.dsc
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody1.diff.gz
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/p/phpsysinfo/phpsysinfo_2.0-3woody1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.