Debian Security Advisory

DSA-348-1 traceroute-nanog -- integer overflow, buffer overflow

Date Reported:
11 Jul 2003
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 7994.
In Mitre's CVE dictionary: CVE-2003-0453.
More information:

traceroute-nanog, an enhanced version of the common traceroute program, contains an integer overflow bug which could be exploited to execute arbitrary code. traceroute-nanog is setuid root, but drops root privileges immediately after obtaining raw ICMP and raw IP sockets. Thus, exploitation of this bug provides only access to these sockets, and not root privileges.

For the stable distribution (woody) this problem has been fixed in version 6.1.1-1.3.

For the unstable distribution (sid) this problem will be fixed soon. See Debian bug #200875.

We recommend that you update your traceroute-nanog package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.