Рекомендация Debian по безопасности

DSA-355-1 gallery -- перекрёстные между сайтами скрипты

Дата сообщения:
30.07.2003
Затронутые пакеты:
gallery
Уязвим:
Да
Ссылки на базы данных по безопасности:
В базе данных Bugtraq (на SecurityFocus): Идентификатор BugTraq 8288.
В каталоге Mitre CVE: CVE-2003-0614.
Более подробная информация:

Ларри Нгуен (Larry Nguyen) обнаружил уязвимость, позволяющую писать скрипты, перекрёстные между сайтами, в gallery, написанном на php web-ориентированном фотоальбоме. Это уязвимое место может позволить злонамеренному пользователю создать URL, выполняющий код на Javascript на вашем web-сайте.

В текущем стабильном дистрибутиве (woody) эта проблема исправлена в версии 1.25-8woody1.

В нестабильном дистрибутиве (sid) эта проблема исправлена в версии 1.3.4-3.

Мы рекомендуем вам обновить пакет gallery.

Исправлено в:

Debian GNU/Linux 3.0 (woody)

Исходный код:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody1.dsc
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody1.diff.gz
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody1_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.