Debian Security Advisory

DSA-365-1 phpgroupware -- several vulnerabilities

Date Reported:
05 Aug 2003
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 8088.
In Mitre's CVE dictionary: CVE-2003-0504, CVE-2003-0599, CVE-2003-0657.
More information:

Several vulnerabilities have been discovered in phpgroupware:

  • CAN-2003-0504: Multiple cross-site scripting (XSS) vulnerabilities in Phpgroupware (aka webdistro) allow remote attackers to insert arbitrary HTML or web script, as demonstrated with a request to index.php in the addressbook module.
  • CAN-2003-0599: Unknown vulnerability in the Virtual File System (VFS) capability for phpGroupWare 0.9.16preRC and versions before with unknown implications, related to the VFS path being under the web document root.
  • CAN-2003-0657: Multiple SQL injection vulnerabilities in the infolog module of phpgroupware could allow remote attackers to execute arbitrary SQL statements.

For the stable distribution (woody), these problems have been fixed in version 0.9.14-0.RC3.2.woody2.

For the unstable distribution (sid), these problems will be fixed soon. Refer to Debian bug #201980.

We recommend that you update your phpgroupware package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.