Debian Security Advisory

DSA-372-1 netris -- buffer overflow

Date Reported:
16 Aug 2003
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 8400.
In Mitre's CVE dictionary: CVE-2003-0685.
More information:

Shaun Colley discovered a buffer overflow vulnerability in netris, a network version of a popular puzzle game. A netris client connecting to an untrusted netris server could be sent an unusually long data packet, which would be copied into a fixed-length buffer without bounds checking. This vulnerability could be exploited to gain the privileges of the user running netris in client mode, if they connect to a hostile netris server.

For the current stable distribution (woody) this problem has been fixed in version 0.5-4woody1.

For the unstable distribution (sid) this problem is fixed in version 0.52-1.

We recommend that you update your netris package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.