Debian Security Advisory

DSA-388-1 kdebase -- several vulnerabilities

Date Reported:
19 Sep 2003
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 8635, BugTraq ID 8636.
In Mitre's CVE dictionary: CVE-2003-0690, CVE-2003-0692.
More information:

Two vulnerabilities were discovered in kdebase:

  • CAN-2003-0690:

    KDM in KDE 3.1.3 and earlier does not verify whether the pam_setcred function call succeeds, which may allow attackers to gain root privileges by triggering error conditions within PAM modules, as demonstrated in certain configurations of the MIT pam_krb5 module.

  • CAN-2003-0692:

    KDM in KDE 3.1.3 and earlier uses a weak session cookie generation algorithm that does not provide 128 bits of entropy, which allows attackers to guess session cookies via brute force methods and gain access to the user session.

These vulnerabilities are described in the following security advisory from KDE:

For the current stable distribution (woody) these problems have been fixed in version 4:2.2.2-14.7.

For the unstable distribution (sid) these problems will be fixed soon.

We recommend that you update your kdebase package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.