Debian-Sicherheitsankündigung

DSA-396-1 thttpd -- Fehlende Eingabeentschärfung, falsche Berechnung

Datum des Berichts:
29. Okt 2003
Betroffene Pakete:
thttpd
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 8906, BugTraq ID 8924.
In Mitres CVE-Verzeichnis: CVE-2002-1562, CVE-2003-0899.
Weitere Informationen:

Mehrere Verwundbarkeiten wurden in thttpd entdeckt, einem kleinen HTTP-Server.

Das Common Vulnerabilities and Exposures Projekt identifiziert die folgenden Verwundbarkeiten:

  • CAN-2002-1562: Informationsleck

    Marcus Breiing entdeckte, dass falls thttpd für virtuelles Hosten verwendet wird und ein Angreifer eine speziell erstelle »Host:« Kopfzeile mit einem Pfadnamen statt einem Rechnernamen liefert, thttpd Informationen über das laufende System ausgibt. Dadurch könnte ein Angreifer die gesamte Platte abfragen.

  • CAN-2003-0899: Willkürliche Code-Ausführung

    Joel Söderberg und Christer Öberg entdeckten einen entfernten Überlauf, der es einem Angreifer erlaubt, das EBP-Register teilweise zu überschreiben und dadurch willkürlichen Code auszuführen.

Für die stable Distribution (Woody) wurden diese Probleme in Version 2.21b-11.2 behoben.

Für die unstable Distribution (Sid) wurden diese Probleme in Version 2.23beta1-2.3 behoben.

Wir empfehlen Ihnen, Ihr thttpd-Paket unverzüglich zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2.dsc
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2.diff.gz
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_alpha.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_arm.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_i386.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_ia64.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_hppa.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_m68k.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_mips.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_mipsel.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_powerpc.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_s390.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/t/thttpd/thttpd_2.21b-11.2_sparc.deb
http://security.debian.org/pool/updates/main/t/thttpd/thttpd-util_2.21b-11.2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.