Aviso de seguridad de Debian

DSA-417-1 linux-kernel-2.4.18-powerpc+alpha -- comprobación de límites inexistente

Fecha del informe:
7 de ene de 2004
Paquetes afectados:
kernel-patch-2.4.18-powerpc, kernel-image-2.4.18-1-alpha
Vulnerable:
Referencias a bases de datos de seguridad:
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 9356.
En el diccionario CVE de Mitre: CVE-2003-0961, CVE-2003-0985.
Información adicional:

Paul Starzetz descubrió una debilidad en la comprobación de los límites en mremap() en el núcleo Linux (presente en las versiones 2.4.x y 2.6.x), que podría permitir a un atacante remoto obtener privilegios de root. Este error no afecta a la versión 2.2.

Andrew Morton descubrió la inexistencia de una comprobación de límites en la llamada al sistema brk que se podría usar para lograr un aprovechamiento remoto de root.

Para la distribución estable (woody), estos problemas se han corregido en la versión 2.4.18-12 para la arquitectura alpha y en la versión 2.4.18-1woody3 para la arquitectura powerpc.

Para la distribución inestable (sid), en breve se subirán paquetes nuevos que corregirán estos problemas.

Le recomendamos que actualice sus paquetes del núcleo. Estos problemas también se ha corregido en la versión 2.4.24 del original.

Arreglado en:

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.18/kernel-source-2.4.18_2.4.18-14.1.dsc
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.18/kernel-source-2.4.18_2.4.18-14.1.diff.gz
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.18/kernel-source-2.4.18_2.4.18.orig.tar.gz
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-1-alpha/kernel-image-2.4.18-1-alpha_2.4.18-12.dsc
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-1-alpha/kernel-image-2.4.18-1-alpha_2.4.18-12.tar.gz
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.18-powerpc/kernel-patch-2.4.18-powerpc_2.4.18-1woody3.dsc
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.18-powerpc/kernel-patch-2.4.18-powerpc_2.4.18-1woody3.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.18/kernel-doc-2.4.18_2.4.18-14.1_all.deb
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.18/kernel-source-2.4.18_2.4.18-14.1_all.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.18-powerpc/kernel-patch-2.4.18-powerpc_2.4.18-1woody3_all.deb
Alpha:
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-1-alpha/kernel-headers-2.4.18-1_2.4.18-12_alpha.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-1-alpha/kernel-headers-2.4.18-1-generic_2.4.18-12_alpha.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-1-alpha/kernel-headers-2.4.18-1-smp_2.4.18-12_alpha.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-1-alpha/kernel-image-2.4.18-1-generic_2.4.18-11_alpha.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-1-alpha/kernel-image-2.4.18-1-smp_2.4.18-11_alpha.deb
PowerPC:
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.18-powerpc/kernel-headers-2.4.18_2.4.18-1woody3_powerpc.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.18-powerpc/kernel-image-2.4.18-newpmac_2.4.18-1woody3_powerpc.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.18-powerpc/kernel-image-2.4.18-powerpc_2.4.18-1woody3_powerpc.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.18-powerpc/kernel-image-2.4.18-powerpc-smp_2.4.18-1woody3_powerpc.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso revisado.