Debian Security Advisory

DSA-420-1 jitterbug -- improperly sanitised input

Date Reported:
12 Jan 2004
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 9397.
In Mitre's CVE dictionary: CVE-2004-0028.
More information:

Steve Kemp discovered a security related problem in jitterbug, a simple CGI based bug tracking and reporting tool. Unfortunately the program executions do not properly sanitize input, which allows an attacker to execute arbitrary commands on the server hosting the bug database. As mitigating factors these attacks are only available to non-guest users, and accounts for these people must be setup by the administrator making them "trusted".

For the stable distribution (woody) this problem has been fixed in version 1.6.2-4.2woody2.

For the unstable distribution (sid) this problem has been fixed in version 1.6.2-4.5.

We recommend that you upgrade your jitterbug package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.