Debian Security Advisory

DSA-421-1 mod-auth-shadow -- password expiration

Date Reported:
12 Jan 2004
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 9404.
In Mitre's CVE dictionary: CVE-2004-0041.
More information:

David B Harris discovered a problem with mod-auth-shadow, an Apache module which authenticates users against the system shadow password database, where the expiration status of the user's account and password were not enforced. This vulnerability would allow an otherwise authorized user to successfully authenticate, when the attempt should be rejected due to the expiration parameters.

For the current stable distribution (woody) this problem has been fixed in version 1.3-3.1woody.1

For the unstable distribution (sid) this problem has been fixed in version 1.4-1.

We recommend that you update your mod-auth-shadow package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.